2002 kia sedona 2.9 diesel coolant problem - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 05-30-2011, 04:11 PM Thread Starter
Newbie
 
Join Date: May 2011
Posts: 6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default 2002 kia sedona 2.9 diesel coolant problem

2002 (52) plate KIA sedona 2.9 crdi L
just wondering if anyone has owned one or got some experience as i have one and it is running fine Ive had it about 6 months now but since i got it i have needed to put around 1 to 1 and a half litre of water in the coolant system every 2 to 3 weeks its concerning me as the KIA has no min or max for the water it goes into the radiator cap the min and max is only on the reserve water tank if it over heats etc which it has never done but just wondering if that is normal as not all cars has to full to the top with water any help would be great thanks.. i dont know if im doin the car any favours filling it to the top with water every 2 to 3 weeks
thebigyin is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 05-30-2011, 04:43 PM Thread Starter
Newbie
 
Join Date: May 2011
Posts: 6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

the temp gage stays fine never goes by half way,,there is no mixing with oil/water..Ive checked for leaks under the car i cant see any leaks etc..it starts first time and drives good no misfire or anything like that,its the topping it up with 1 to 1 and a half litre of water every 3 weeks that is worrying me..is this normal for the KIA sedona
thebigyin is offline  
post #3 of 8 (permalink) Old 05-31-2011, 07:03 AM
Banned
 
Join Date: Aug 2007
Posts: 467
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Quote:
Originally Posted by thebigyin View Post
the temp gage stays fine never goes by half way,,there is no mixing with oil/water..Ive checked for leaks under the car i cant see any leaks etc..it starts first time and drives good no misfire or anything like that,its the topping it up with 1 to 1 and a half litre of water every 3 weeks that is worrying me..is this normal for the KIA sedona
Its not normal to have to keep putting water into a car on a 3 weekly cycle. Take the spare wheel off under the car and check for dampness on the 2 rear heater pipes. Do it after a run when the engine is hot and leave the engine running( have someone sat inside it to stop some scrote nicking it) then check underneath, Also check the drivers side front for leaks and check the carpet inside to see if its damp
bruno1926 is offline  
post #4 of 8 (permalink) Old 05-31-2011, 08:19 AM Thread Starter
Newbie
 
Join Date: May 2011
Posts: 6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

Quote:
Originally Posted by bruno1926 View Post
Its not normal to have to keep putting water into a car on a 3 weekly cycle. Take the spare wheel off under the car and check for dampness on the 2 rear heater pipes. Do it after a run when the engine is hot and leave the engine running( have someone sat inside it to stop some scrote nicking it) then check underneath, Also check the drivers side front for leaks and check the carpet inside to see if its damp
ok mate thanks i will check that out
thebigyin is offline  
post #5 of 8 (permalink) Old 06-10-2011, 01:56 AM Thread Starter
Newbie
 
Join Date: May 2011
Posts: 6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

today my heater just blew cold air and i checked the coolant and it needed 2 litre of water and then the heater blew warm again what could the problem be ,,head gasket,,matrix etc any help would be great thanks
thebigyin is offline  
post #6 of 8 (permalink) Old 06-14-2011, 08:02 AM
Member
 
Join Date: Apr 2009
Location: lorca,murcia,spain
Posts: 70
Drives: 2003 carnival 2,9 ex auto
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Bruno told you . It's 99,9% that it's the rear heater pipes, as it's a common fault.
mio cid is offline  
post #7 of 8 (permalink) Old 06-15-2011, 08:51 AM Thread Starter
Newbie
 
Join Date: May 2011
Posts: 6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Post

i noticed a leak today just under the drivers door its a steel pipe joined onto a rubber pipe do i need to buy the steel pipe to fix it or are they anything i can do to repair it like using gum gum paste or something like that
thebigyin is offline  
post #8 of 8 (permalink) Old 06-27-2011, 10:48 AM Thread Starter
Newbie
 
Join Date: May 2011
Posts: 6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

i replaced it with a heavy duty rubber one thanks for your helpful replies
thebigyin is offline  
Sponsored Links
Advertisement
 
Reply

  Kia Forum > KIA Models > Kia Carnival & Sedona Forum > Kia Carnival & Sedona

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On