rough cold idle - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-20-2013, 04:22 PM Thread Starter
Newbie
 
Join Date: Jan 2013
Posts: 2
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default rough cold idle

2006 kia sedonna idles rough when cold started and spits and sputters under acceleration. Engine light is on,had checked at Autozone and was told to start with changing fuel filter. Any ideas ?
xspired is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-21-2013, 09:42 AM
Veteran
 
GregsKia's Avatar
 
Join Date: Feb 2011
Location: Manistee, Michigan, USA
Posts: 1,120
Drives: Two-06 Sedona LX,06 Sedona EX,07 Optima EX, 13 Optima HEV LX, 09 Amanti, 14 Forte EX, 11 Sportage EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Garage

Default

What was the code? Should start with a "P". I wouldn't trust exactly what they tell you at the auto parts store when it comes to diagnosis. If you provide the code, I will check it for you in Kia's code manual. You can also register at kiatechinfo.com and access all of the service manuals for your vehicle.

Vehicles: 06 Sedona EX, 237k miles---06 Sedona LX, 258k miles---07 Optima EX 2.4L, 96k miles---13 Optima Hybrid LX, 19k miles---09 Amanti, 88k miles---14 Forte EX 2.0L, Prem+Tech, 89k miles---11 Sportage EX AWD 2.4L, Prem+Nav, 88k miles---15 Sedona SX, 4k miles

Last edited by GregsKia; 01-21-2013 at 09:44 AM.
GregsKia is offline  
post #3 of 4 (permalink) Old 01-28-2013, 12:30 PM
Newbie
 
Join Date: Apr 2007
Location: topeka, ks
Posts: 14
Drives: 2006 sedona lx
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

I would bet its the throttle position sensor.
06newowner is offline  
post #4 of 4 (permalink) Old 01-28-2013, 03:38 PM
Newbie
 
Join Date: Oct 2011
Posts: 4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

I had a torn air intake duct before that acted similarly. It was torn underneath where it was hard to see. It caused it to run lean at idle, which if I recall would be worse when cold.

Be sure and find out what codes it is tripping.

"Start with the fuel filter" = I have no idea, but I'm happy to give useless advice anyway!
mtaviator is offline  
Reply

  Kia Forum > KIA Models > Kia Carnival & Sedona Forum > Kia Carnival & Sedona 2006+

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On