ESC light off on going problem - Kia Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 09-16-2010, 08:21 AM
Newbie
 
yvmor's Avatar
 
Join Date: Sep 2010
Location: Ottawa, Canada
Posts: 6
Drives: 2007, Rondo, V6 EX luxury
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Thumbs down ESC light off on going problem

I have seen a few a few posts regarding this but no fix has resolved my issue. I bought my 07 Rondo new and now have 55,000KM on it. From about 8000KM (2.5years) is have had the issue of my ESC light off coming on by itself and then the check engine. The issue only happens in the summer months and I learnt the hard way during a 4000KM trip is also affects the cruise control. Needless to say I am on my 3rd dealership and just finished my 13 trip to get this resolved. So far they have changed.
- Put silicone on some sensors
- Replaced sensors
- Brake switch (twice)
- Unhooked all the electrical and reconnected
- Replaced the ABS computer and assembly
- Changed the fuse box and all the relays
- The latest is the main computer (had loaner for 2 weeks)
Not to knock on the dealership because they were nice and were following the Kia Engineers advise but Kia head office wasted about a month of my life refusing to accept to change the main computer because of the cost even though the mechanic suspected it. Not to say this is the fix because just got my car back yesterday and since this problem only happens when itís 25 Celsius or hotter I will have to wait. Being a 2nd time Kia owner and the that I had had this issue now for 2.5 years I wrote the head office a complaint and in typical head office fashion I got a so sorry we have wasted so much of your time, we have to honour the warranty and will continue to work to fix it because itís the law. Anyhow enough with the venting Iíll remember there poor response when I buy my future vehicles. The goal was to post the issue for anyone else in case they have encountered the same problem.
yvmor is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 09-16-2010, 08:34 AM
PLP
Super Moderator
 
PLP's Avatar
 
Join Date: Dec 2008
Location: Haslett, MI, USA, Earth
Posts: 5,666
Drives: 2007 Kia Rondo EX V6 2.7 5P A/T; 2009 Hyundai Elantra GLS, 2.0, I4, 5 SPD M/T sedan
Gallery: 3
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 30 Post(s)
Garage

Default

I wonder if they (KIA service) at least tried to think about the whole process of ESC activation or they simply started replacing parts to see what will happen... like it was with my case.

Anyway, ESC detects how fast the wheels are spinning, right? So, is there any particular situation, anything in common when it gets activated? Straight road? Bump? Rain? Low/high speed? Cold/hot engine...

What could trigger it is for instance dirt, voltage drop... Of course, computer fault too, but I am not 100% convinced that this would be the only issue the computer had (if the computer fails, many weird things would happen).


Keep us updated... and if you could - add info to your profile, please.

www.kiatechinfo.com USA - free service, manuals www.kia.ca/kia-owners-manuals Canada www.kia-hotline.com Europe (paid service!) www.kia.ca/pages/owner/OwnersManual.aspx?lang=en manuals - must pick model, Canadian version - for free
PRINT IT and put on your car Do you talk/text and drive? Watch it: http://www.oprah.com/oprahshow/Watch...bsession-Video
PLP is offline  
#3 (permalink) Old 09-16-2010, 01:36 PM
Full Member
 
Join Date: Apr 2009
Location: Orlando
Posts: 103
Drives: 2008 Rondo LX - 2011 Forte EX
Gallery: 5
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

I have an 08 Rondo with V6. I have gotten this warning light as well BUT NEVER while driving only when starting the car up. I just shut it off and restart it and the light is gone.

Seems KIA must use WINDOZE operating system to manage its controls

BTW, I have only had my blower fans run full blast only TWICE since getting the vehicle, glad that one stopped and of course, the dealer says 'it has to be happening in order for us to find it' yeah right.

Hope you get your problem solved.
Tony_K is offline  
#4 (permalink) Old 09-16-2010, 03:41 PM
Senior Member
 
Urban07's Avatar
 
Join Date: Dec 2008
Location: So. California
Posts: 253
Drives: 2007 Kia Rondo EX V6
Gallery: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

My 07 Ex V6 has the same problem the ESC light comes on for no reason...stays on while driving even if you push the dash switch nothing happens..Turn the car off and restart it and it goes off...I never had taken it to the dealer for this as I know they will tell me it working fine. So I live with it from time to time.
Urban07 is offline  
#5 (permalink) Old 09-16-2010, 06:00 PM
Full Member
 
cjfin's Avatar
 
Join Date: Nov 2007
Location: BC, Canada
Posts: 183
Drives: 2007 Kia Rondo EX-V6 Luxury, 1990 Suzuki Escudo
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

We had a similar problem about 2 years ago with ours. Kia fixed it under warranty and it has been fine ever since. Something about a sensor or switch as I recall. I can try to look back in our records to see what items were replaced if it helps any.
cjfin is offline  
#6 (permalink) Old 09-16-2010, 10:11 PM
Member
 
autoservice's Avatar
 
Join Date: Aug 2010
Location: Colorado
Posts: 42
Drives: 2010 Kia Soul + and Ford Ranger STX 4x4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

yvmor - Very unfortunate you have had so many issue's. I can tell you that here in the USA they recalled the Brake light switch which causes that issues (also if the rear brake lamp bulbs are burned out it will cause this issue). I can tell you that even afater doing the recall we would have several vehicles come back at least ywice and we would have to replace the brake light switch again!! Go figure, a brake light switch if you have seen one is a pretty simple device. Either way we had at least 3 people come back 3 times and finally the switch fix it. I think they are missing something really basic, have never heard or seen of your issue. Makes no sense to be honest. I would call KIA again and demand that they send out a engineer to look at toyu vehicle. If you insist they should do it especially with all the repairs they have done on that vehicle. Either that or go to what ever goverment agancy you have where you are from and compain to them. Someone will do something eventually, I would hope!!

Check out my blog at AutomotiveService101
Learn about automotive scams and protect youself!!
autoservice is offline  
#7 (permalink) Old 09-16-2010, 10:13 PM
Member
 
autoservice's Avatar
 
Join Date: Aug 2010
Location: Colorado
Posts: 42
Drives: 2010 Kia Soul + and Ford Ranger STX 4x4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Quote:
Originally Posted by cjfin View Post
We had a similar problem about 2 years ago with ours. Kia fixed it under warranty and it has been fine ever since. Something about a sensor or switch as I recall. I can try to look back in our records to see what items were replaced if it helps any.
Like I mentioned above you probably have a recall on your vehicle. Try going to the dealership once and awhile, they check those things when you bring it in for service. One of the advantages of bringing your vehicle to the dealership.

I totally understand why people do not go to the delaership. Check out my blog.....

Check out my blog at AutomotiveService101
Learn about automotive scams and protect youself!!
autoservice is offline  
#8 (permalink) Old 09-18-2010, 08:37 AM
Full Member
 
Dakota29803's Avatar
 
Join Date: Dec 2006
Location: Aiken, SC
Posts: 109
Drives: 2007 Kia Rondo 5 seat EX I4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

I have had the ESC light come on about four or five times in the 3 1/2 years that I have owned the car. It always goes away within two or three days, if that long. I also had a check engine light once that I took to the Firestone dealer where I have my usual work done. He used his scan tool and told me what it said that the problem was, and that I should take it to the KIA dealer. I asked him to reset the light and that I would take it to the dealer if it returned. It has not returned in over a year. I also have had spurious TPMS lights on a few occasions (the tires were normal pressure). I think that the computer is subject to external noise spikes. I am not going to drive a 50 mile round trip to the dealer to find out that there is no problem. It would be interesting to know if a replacement computer helps.
Dakota29803 is offline  
#9 (permalink) Old 09-18-2010, 10:21 AM
Member
 
autoservice's Avatar
 
Join Date: Aug 2010
Location: Colorado
Posts: 42
Drives: 2010 Kia Soul + and Ford Ranger STX 4x4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Quote:
Originally Posted by Dakota29803 View Post
I have had the ESC light come on about four or five times in the 3 1/2 years that I have owned the car. It always goes away within two or three days, if that long. I also had a check engine light once that I took to the Firestone dealer where I have my usual work done. He used his scan tool and told me what it said that the problem was, and that I should take it to the KIA dealer. I asked him to reset the light and that I would take it to the dealer if it returned. It has not returned in over a year. I also have had spurious TPMS lights on a few occasions (the tires were normal pressure). I think that the computer is subject to external noise spikes. I am not going to drive a 50 mile round trip to the dealer to find out that there is no problem. It would be interesting to know if a replacement computer helps.
Kia does not have to many issues with their ECU's they are faily dependable. As for not going to the dealer maybe try calling them. You happen to have 3 possible recalls on that vehicle, one for brk light switch (that would explain you ESC light coming on and just so you know it will cause your brake lights to be inopertive, possible accident waiting to happen), one for a wheel speed sensor issue (can cause ABS brakes to go inop) and a airbag module recall - The recalls are SC069, 071 and 077. If you are not willing to drive to the dealer then maybe call them and find out if any of these apply. Wonder why the firestone guy did not know this....Sometimes it is worth the trip to the dealer, unless they are a crappy dealer they happen to know more about your vehicle then firestone. Would you drive 50 miles to go to your doctor??

As for the TPMS sensor these can be pretty sensative. They are prone to some interferance (you will know it is interferance because it will always happen when you drive by the same place all the time). Tire pressures do fluxuate with hot and cold temps (not just outside temps but tire temp as you drive). So if the outside temp is much lower then the temp that you set the tire pressure at you may see the light come on. I suggest putting 2 psi more air then what it states on the door. Rondos I believe are recommended at 30psi (you need to verify). I would set between 32 and 34. You will get better wear on the tires at these pressures anyways. The lower tire pressure gives you a little better handling but in my opinion 2 to 4 psi will not be very noticable (it will also slightly increase fuel mileage).

Last thing is your service engine light. Eventually that light may catch up with you depending on what is coding up. You have a warranty, us it. If you wait and the vehicle goes out of warranty KIA will not care that it has been going on and off for the last 3 years. The trip may be worth it because down the road that check engine light may cost you a couple hundred dollars. It is up to you in the long run but you do have a warranty you might as well take advantage of it. There happens to be a couple updated programs for the service engine light that once again may apply to your vehicle. These will not be covered under warranty when the warranty goes out and Firestone can't do them for you and they obviously do not know about them either (and if they did the would tell you to go to the dealer like they already have, why waist your "time" with them).

Just trying to give you some good advise and help you get the most out of your vehicle...


Check out my blog at AutomotiveService101
Learn about automotive scams and protect youself!!

Last edited by autoservice; 09-18-2010 at 10:30 AM.
autoservice is offline  
#10 (permalink) Old 09-18-2010, 05:38 PM
Full Member
 
cjfin's Avatar
 
Join Date: Nov 2007
Location: BC, Canada
Posts: 183
Drives: 2007 Kia Rondo EX-V6 Luxury, 1990 Suzuki Escudo
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Regarding my last post, I have the following update.

I looked back in our paperwork and found Kia fixed our problem by following the corrective action outlined in their recall number RC072. Where I live it is Transport Canada Recall #2009140.

Seeing that you have had your vehicle to the dealership several times, I can't imagine that they haven't done this fix for you. I hope you get your problem resolved.
cjfin is offline  
Reply

  Kia Forum > KIA Models > Kia Carens & Rondo Forum


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On