2009 Rondo TSB021 Front Strut Noise - Kia Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-08-2010, 02:18 PM
Memorial Super Moderator
 
pulsar86's Avatar
 
Join Date: Jul 2009
Location: Sunshine Coast,Queensland, Australia
Posts: 2,863
Drives: 2005 Kia Cerato LD [2L petrol] manual, 1986 Nissan Pulsar hatch
Gallery: 3
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Exclamation 2009 Rondo TSB021 Front Strut Noise

From the kiatechinfo site, relating to retightening struts for a fix of front end noise on some 2009 Rondos. May be of help to some forum members.
Attached Files
File Type: pdf Rondo tsb 021.pdf (390.6 KB, 1653 views)

TAKE YOUR TIME, THINK IT OUT, DO IT RIGHT, DO IT ONCE!! original quote by me as far as I know. :rolleyes:
ALL MEMBERS PLEASE FILL IN USER PROFILES. DETAILS HELP OTHER MEMBERS HELP YOU .
pulsar86 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-19-2010, 05:23 AM
Member
 
Join Date: Oct 2007
Location: Dartmouth, Nova Scotia
Posts: 29
Drives: 2007 Rondo EXV6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

I have a 2007 EXV6 and had to bring mine in twice now for this.

It is not only for 2009 model.
BernieD is offline  
#3 (permalink) Old 03-23-2010, 06:23 AM
Newbie
 
RudyMtl's Avatar
 
Join Date: Oct 2008
Location: Montreal, Quebec, Canada
Posts: 6
Drives: Kia Rondo EX-V6 2008 5P
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

I think as BernieD says, this could be a problem not ONLY for some of the 2009 Rondo's. Mine it's a 2008 EXV6 and after reading this thread, I have the feeling that's it, exactly what it could be happening to my Rondo.

Mine was doing weird noise coming from somewhere the front/left/upper side, when driving over an uneven surface road.

I brought it to the concessionary and they say that the link-kit's need to be changed, so was done, and the noise was «considerably» reduced.

But, given that recently (2 days ago) I have the chance to ride a 2010 Rondo EX, comparing the quietness and softness of it's suspension with mine, I have to say that even with the link-kit's changed, I still ear a noisy suspension over uneven surface roads. So I'll be back to the concessionary and giving updates.

Good to know. I still thinking that KIA is an excellent quality/price ratio. I still believing that Rondo is just a wonderful vehicle.

Mileage: 33,600 km, Ownership: 20 months

Last edited by RudyMtl; 03-23-2010 at 06:27 AM.
RudyMtl is offline  
#4 (permalink) Old 04-16-2010, 09:53 AM
Newbie
 
Join Date: Apr 2010
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default Just had mine in for a recall on this

I've just now returned from the dealer after receiving a recall notice on this. I was quite alarmed on receiving a postcard from them yesterday that I was to bring the car in ASAP, with no indication what needed to be done, other than it was Recall # SA028. I could find no information on such a recall on the web, nor was it listed in the NTSA database.

The postcard also stated that I have been "notified by the manufacturer of the existing problem but have NOT taken steps with us to have the correction made", etc. This was the first I'd heard of it. I received absolutely no notice from Kia on this.

The invoice from this morning's work says "Customer Request recall be performed SA028 Rondo FR strut upper nut retight. Perform recall". So I guess that's it for now.

Interestingly, on 11/13/09 I brought the car in because I heard a noise coming from the front end, and a loose nut on the front strut was reported to have been the problem. It was tightened then, and I've not noticed the noise since. On 2/18/10 I had it in for an oil/filter change and the service rep did a search for any recall issues and he said there were none. I see that the Technical Service Bulletin was issued in Feb 2010, so I guess that must have happened after the 18th.

While I was mollified by the polite and speedy action taken this morning at the service department, which included a chat with the service department manager, I am unhappy with Kia and dealer administration for their sloppy handling of my notification and not being more specific when they sent me the postcard. With all that's been going on recently with recalls, I was wondering if it was even safe to drive it to the service department this morning! And where was that notice from Kia? They've got my correct address, as I get other correspondence from them.

Thanks so much to the original poster for sharing this. I hope this is not going to be an ongoing problem. Other than this, I love my Rondo. I purchased it in August of 2009, and it has only 1253 miles on.
ebmeyer is offline  
#5 (permalink) Old 04-16-2010, 03:31 PM
Memorial Super Moderator
 
pulsar86's Avatar
 
Join Date: Jul 2009
Location: Sunshine Coast,Queensland, Australia
Posts: 2,863
Drives: 2005 Kia Cerato LD [2L petrol] manual, 1986 Nissan Pulsar hatch
Gallery: 3
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thread Starter (Thread Starter)
Thumbs up

Hi ebmeyer and welcome to the KIA forums. If you go to www.kiatechinfo.com and register for free, you can access a lot of information, workshop manuals etc as well as see the same Technical service bulletins that go to the dealers, very helpful with keeping up to date with recalls, problems etc.

TAKE YOUR TIME, THINK IT OUT, DO IT RIGHT, DO IT ONCE!! original quote by me as far as I know. :rolleyes:
ALL MEMBERS PLEASE FILL IN USER PROFILES. DETAILS HELP OTHER MEMBERS HELP YOU .
pulsar86 is offline  
#6 (permalink) Old 06-10-2010, 01:44 PM
Newbie
 
Join Date: Jun 2010
Location: Winnipeg, MB
Posts: 3
Drives: 2008 Rondo EXV6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Quote:
Originally Posted by pulsar86 View Post
From the kiatechinfo site, relating to retightening struts for a fix of front end noise on some 2009 Rondos. May be of help to some forum members.
I just returned from the KIA dealership, having had both front stabilizer links replaced under warranty. The clunking noises started a few days ago, only apparent when driving over uneven road surfaces. The service rep mentioned the stabilizers as being a fairly common problem (parts were in stock), and the replacements have eliminated the clunking noises.

I was surprised at this type of wear & tear with only 26K kms during my 33 months of ownership (2008 model, purchased in Sept. 2007). Otherwise, we're delighted with our Rondo and this is the first problem issue.

I'm a new forum member - 'Hi' to everyone...and I look forward to staying informed via your periodic posts.
Grantpeg is offline  
#7 (permalink) Old 06-10-2010, 03:21 PM
Veteran
 
conwelpic's Avatar
 
Join Date: Apr 2007
Location: PEC, Ontario, Canada
Posts: 6,113
Drives: 2012 Soul 4u, 2.0L, auto, sunroof, UVO - Mint
Gallery: 38
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 75 Post(s)
Garage

Default

Quote:
Originally Posted by Grantpeg View Post
I just returned from the KIA dealership, having had both front stabilizer links replaced under warranty. The clunking noises started a few days ago, only apparent when driving over uneven road surfaces. The service rep mentioned the stabilizers as being a fairly common problem (parts were in stock), and the replacements have eliminated the clunking noises.

I was surprised at this type of wear & tear with only 26K kms during my 33 months of ownership (2008 model, purchased in Sept. 2007). Otherwise, we're delighted with our Rondo and this is the first problem issue.

I'm a new forum member - 'Hi' to everyone...and I look forward to staying informed via your periodic posts.
with your first posting on the forum, good to see another Canadian member.
I too had the two front stabilizer links replaced under warranty a few weeks ago with 58,000 km on the clock. It was a knock that came on quite quick over a few days - solved the problem! The service manager said they had encountered a premature bushing wear on a few on '07 and '08 Rondo's, some at 10,000km some okay till 100,000 km. He knew what it was as soon as I described it to him on the phone when I made the appointment. They too stocked the item and it was in and out in a half hour.
conwelpic is offline  
#8 (permalink) Old 06-24-2010, 06:33 PM
Newbie
 
Join Date: Feb 2010
Posts: 8
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

My 2009 Carens 2.0 crdi has been rattling and clunking from the front end since new..I have complained several times all to no avail..the dealership In lowestoft UK eventually said they had to tighten something..what I dont know..its a bit quieter now however!
kingy is offline  
#9 (permalink) Old 08-21-2010, 08:36 AM
Newbie
 
jacklac's Avatar
 
Join Date: Aug 2010
Location: Edmundston, N.-B Canada
Posts: 17
Drives: Kia, Rondo, 2014, 5 passagers, Blue
Gallery: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage

Default

Thanks Pulsar86 for the kiatechinfo link.
It will be a good help for the next years.
jacklac is offline  
#10 (permalink) Old 09-03-2010, 08:58 AM
Newbie
 
Join Date: Aug 2010
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default Thank You So Much!!!

This PDF saved me a trip to the Carmax service dept and who knows how much money!! A socket wrench and some muscle behind it was all it needed!! Thank you SOOOOO much!! My 09 Rondo feels and sounds like a new car now!
reiddog77 is offline  
Reply

  Kia Forum > KIA Models > Kia Carens & Rondo Forum


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On