2008 EX audio problem - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 01-22-2012, 05:58 PM
Newbie
 
Join Date: Jan 2012
Location: Granada Hills
Posts: 1
Drives: Kia Spectra 2008 EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default 2008 EX audio problem

my car speakers start giving out a vibrating noise whenver i play music with something like drums or high bass from my cd player.Any help is welcome - thanks

Kia Spectra 2008 EX
rimpi96 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 01-22-2012, 07:55 PM
Newbie
 
Join Date: Jan 2012
Posts: 19
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

vibrating noise? is it like scratching noise if so then your speakers are probably shot. other wise speakers vibrating is what makes noise we call music lol couldnt resist.
jmckeon is offline  
#3 (permalink) Old 01-22-2012, 10:37 PM
Veteran
 
KIAZILLA's Avatar
 
Join Date: Jun 2007
Location: Shelton, WA
Posts: 1,495
Drives: 06 KIA Spec5, 96 HD Roadking
Gallery: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Garage

Default

The stock speakers are not known for their quality so I would guess that they are toast. Go with some aftermarket ones.

Last edited by KIAZILLA; 01-22-2012 at 10:38 PM. Reason: forgot a word
KIAZILLA is offline  
#4 (permalink) Old 01-14-2013, 11:06 AM
Member
 
Join Date: Jan 2013
Location: South Dakota
Posts: 28
Drives: 2008 Spectra EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Default

I have the same problem on my front speakers. Maybe its the year and model?
HeWhoDrives is offline  
#5 (permalink) Old 01-14-2013, 01:44 PM
Senior Member
 
Join Date: Sep 2011
Location: Dalton, PA
Posts: 279
Drives: 05 Kia Sorento LX 4x4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Default

My wifes EX does the same, but only when the bass is turned up too much for the speakers. Turn it down and see if that helps any. If it still sounds scratchy or muffled at lower bass levels, than you've more than likely blown the speakers. They're easy to replace, and even cheap aftermarket ones will be a nice improvement over stock.

'05 Sorento LX 4x4. Purchased 9-14-11 43,800mi. "Karinka"
'08 Spectra EX 5speed. Purchased 3-25-12 43,500mi. "Saki"
'99 Sephia 5speed "Kurumi". Traded in 2006.
ratsttam is offline  
#6 (permalink) Old 01-14-2013, 01:52 PM
Super Moderator
 
cobra259's Avatar
 
Join Date: Aug 2010
Location: Waterford MI
Posts: 3,133
Drives: 1995 Procharged Mustang Cobra -- 2006 Grand Cheorkee limted Hemi.
Gallery: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 92 Post(s)

Default

Quote:
Originally Posted by HeWhoDrives View Post
I have the same problem on my front speakers. Maybe its the year and model?
OEM speakers are in no way the best out there. It's not your car, it's the cheap speakers, try some good aftermarket ones and you should be fine. Blaming it on the car won't help, unless your still under warranty.
cobra259 is online now  
#7 (permalink) Old 01-14-2013, 01:58 PM
Senior Member
 
Join Date: Dec 2010
Location: Washington, DC.
Posts: 258
Drives: 2005 Blue Kia Spectra5 and a 96 Turbo Honda civic and a 99 subaru outback with a 2.5 rs turbo motor
Gallery: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

Send a message via Yahoo to tt2jzgtes Send a message via Skype™ to tt2jzgtes
Default

the seal around the speakers maybe gone. mine did the same before. get some silicone glue and take the speakers out more than likely the glue around the cone is gone. just simple re apply glue on to them if not your speakers are blown. i like my factory speakers then match the color of my car which is blue by the way.
tt2jzgtes is offline  
#8 (permalink) Old 02-05-2013, 08:50 AM
Member
 
Join Date: Jan 2013
Location: South Dakota
Posts: 28
Drives: 2008 Spectra EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Default

question for the member above me, isnt your username the name of the engine the use in the Silvia 240sx's?
HeWhoDrives is offline  
#9 (permalink) Old 02-06-2013, 10:13 AM
Senior Member
 
Join Date: Dec 2010
Location: Washington, DC.
Posts: 258
Drives: 2005 Blue Kia Spectra5 and a 96 Turbo Honda civic and a 99 subaru outback with a 2.5 rs turbo motor
Gallery: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

Send a message via Yahoo to tt2jzgtes Send a message via Skype™ to tt2jzgtes
Default

Quote:
Originally Posted by HeWhoDrives View Post
question for the member above me, isnt your username the name of the engine the use in the Silvia 240sx's?
No. the old S13-14 Silvia's uses a redtop Sr20det and some newer S14 and all S15 uses the black top SR20DETs. My SN is an MK4 Toyota Supra engine.
tt2jzgtes is offline  
Reply

  Kia Forum > KIA Models > Kia Cerato, Shuma & Spectra Forum > Cerato (2003 - 2008) & Spectra5 (2004)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On