2006 kia spectra heater problems - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 01-17-2012, 09:57 AM Thread Starter
Newbie
 
Join Date: Jan 2012
Posts: 19
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default 2006 kia spectra heater problems

i have a 2006 kia spectra and am having heater issues. only time i get heat is when the dial is set on 4 i get no heat and blower motor does not work on settings 1-3 i am not sure what is going on. this all started about a month ago and is gradually getting worse. now it only works on 4 sometimes and you have to smack dash by heater dialsto get 4 to kick on when it doesnt turn on or sometimes it just turns on whe u turn it to 4 but on settings 1-3 nothing. is it a bad dial, bad blower motor, or something else i have mechanical knowledge nd wanna change it but not sure what is the issure any help would b appreciated please and thank you
jmckeon is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 01-17-2012, 10:17 AM
Super Moderator
 
cobra259's Avatar
 
Join Date: Aug 2010
Location: Waterford MI
Posts: 3,233
Drives: 1995 Procharged Mustang Cobra -- 2006 Grand Cheorkee limted Hemi.
Gallery: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 107 Post(s)

Default

You have a bad blower motor resister.
cobra259 is online now  
post #3 of 7 (permalink) Old 01-17-2012, 10:30 AM Thread Starter
Newbie
 
Join Date: Jan 2012
Posts: 19
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

where is that located?
jmckeon is offline  
post #4 of 7 (permalink) Old 01-20-2012, 07:53 PM Thread Starter
Newbie
 
Join Date: Jan 2012
Posts: 19
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

ok update. got the new blower motor resistor today installed and plugged it in turned the car on and turned the fan on and nothing still. car now has no fan period so no heat this is my wifes car and getting parts for this is a pain as everything has to be special ordered inorder to get it. the fan decided to quit working yesterday and today it was minus 5 degrees here so reall y need to get this fixed asap. plan on ordering a blower motor hope thats the issue if not im clueless but dont want to take it to dealer as they told me it will be minimum of 500 for them to test diagnose and repair what ever is wrong. anyone with any knowledge of this heating system please help. we need the fan to work so she dont freeze.
jmckeon is offline  
post #5 of 7 (permalink) Old 01-20-2012, 09:12 PM Thread Starter
Newbie
 
Join Date: Jan 2012
Posts: 19
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

well figured out problem with heater issues. got mad started tearing it all apart jumped blower motor and that worked fine so moved to relays they all were in working order. so i moved to control cluster. and DING DING DING thats where it is i started removing the control cluster heat kick on upon tinkering either the circuit board in the a/c heater cluster is bad or the blower dial unit is bad either way im sure its either salvage yard or dealer only so ill be calling them in the morning.
jmckeon is offline  
post #6 of 7 (permalink) Old 01-21-2012, 01:02 PM
Veteran
 
KIAZILLA's Avatar
 
Join Date: Jun 2007
Location: Shelton, WA
Posts: 1,499
Drives: 06 KIA Spec5, 96 HD Roadking
Gallery: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Garage

Default

Thanks for reporting back, it may help someone else down the road.
KIAZILLA is offline  
post #7 of 7 (permalink) Old 01-21-2012, 01:12 PM Thread Starter
Newbie
 
Join Date: Jan 2012
Posts: 19
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

wasnt a hard fix once i figured it out. the climate controls( heater controls) are the same for a 04-06 kia spectra. you take a flat head screw driver and insert it in the sides of the black center piece where radio and climate controls are near bottm on sides by the heater controls and pop it out on each side then work up gently pulling the center unit it out as it only clips in there are no screws. once out pop the wire plugs out of there ports and whole center unit minus radio will come right out. *NOTE* if chsnging radio this is same process to go through to be able to remove radio. once the center unit is out just unscrew 4 black screws that hold climate control to center unit and replace with new one screw back in plug in all wires and just slid the center unit back in relatively easy fix. took longer to type it then it did to do it lol. i picked part up from salvage yard got 40 bucks in to replacement so cant complain.
jmckeon is offline  
Sponsored Links
Advertisement
 
Reply

  Kia Forum > KIA Models > Kia Cerato, Shuma & Spectra Forum > Cerato (2003 - 2008) & Spectra5 (2004)

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On