2005 Spectra5 Fast turn signal - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 09-20-2011, 10:18 PM
Newbie
 
Join Date: Sep 2011
Location: Atlanta, GA
Posts: 3
Drives: 2005 Spectra5
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default 2005 Spectra5 Fast turn signal

Hi,

Just purchased a 2005 Kia Spectra5. Wouldn't you know, after a week of driving, the left turn signal blinks twice as fast as normal. Checking outside of the vehicle, both front and rear signals illuminate, but are much dimmer than the correctly functioning passenger side.

Doing a forum search, I saw it suggested that this could be a ground/current issue. Thus far I've:

Replaced all four turn signal bulbs (front, rear, drivers and passengers), cleaned the battery contacts, and cleaned both ground contacts where the wiring harness is bolted to the hood.

I've also noticed that the headlamps do not illuminate until the car is cranked. I'm not sure if this another symptom of the problem, or just normal operation for the vehicle.

Any other ideas as to what I can do to narrow down the issue? Thanks!
fireburns is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 09-25-2011, 03:15 PM
Newbie
 
Join Date: Sep 2011
Location: Atlanta, GA
Posts: 3
Drives: 2005 Spectra5
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default

For those interested, it was a contact issue with the front signal bulb and socket.

I ended up removing the battery to better get at the assembly and removed both the bulb from the socket and the socket from the wiring harness. I cleaned each connecting area and made sure the bulb was seated all the way. Judging by the condition of the original bulb, I'd say I had a failing bulb, but did not properly seat my new one, which is why the fast signal issue didn't go away.

Hope this helps somebody else who might happen to have the same issue...
fireburns is offline  
#3 (permalink) Old 11-29-2011, 08:15 PM
Member
 
Join Date: Mar 2008
Location: Inland Northwest
Posts: 70
Drives: Black 2007 Spectra EX, 19.2mm Tib rear bar.
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Good info. The bad contact was acting just like a bad bulb, hence the fast blinker.
LAMRONH is offline  
#4 (permalink) Old 01-05-2012, 04:38 PM
Newbie
 
Join Date: Jan 2012
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

I had same issue and it was the ground wire from wire harness right by battery bolted to frame
Just a FYI
Billiardking is offline  
Reply

  Kia Forum > KIA Models > Kia Cerato, Shuma & Spectra Forum > Cerato (2003 - 2008) & Spectra5 (2004)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On