Please Help with 2006 Spectra Transmission - Kia Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 02-02-2010, 04:17 PM
Newbie
 
Join Date: Feb 2010
Posts: 6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default Please Help with 2006 Spectra Transmission

I have had my 2006 Spectra for three years now. The transmission has been flushed once since I have owned it and the fluids are at the right level.

This is what happens:
I get in my car and it runs normal, shifting from 1st to 2nd and so on. Then about 20 mins into the drive it jerks like the car is getting ready to throw up and it drops into a lower gear. If I am on the highway and this happens the RPMs go up to 4000 while going 70mph.

Please help.

Thanks,
GMac
macaluso624 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-03-2010, 05:29 PM
Member
 
Join Date: Mar 2009
Location: New Paltz, NY
Posts: 64
Drives: 2005 Spectra/Cerato
Gallery: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Send a message via AIM to Bakwoods
Default

Tell me this batman...you have automatic? It wouldn't be a vaccuum leak...so next best bet is a tranny sensor. If there's a CEL code...tell us that first.
Bakwoods is offline  
#3 (permalink) Old 02-04-2010, 01:16 PM
Newbie
 
Join Date: Feb 2010
Posts: 6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

How do I find out the CEL code?
macaluso624 is offline  
#4 (permalink) Old 02-04-2010, 02:14 PM
Memorial Super Moderator
 
pulsar86's Avatar
 
Join Date: Jul 2009
Location: Sunshine Coast,Queensland, Australia
Posts: 2,863
Drives: 2005 Kia Cerato LD [2L petrol] manual, 1986 Nissan Pulsar hatch
Gallery: 3
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Default

Youy will have to go to a garage or somewhere who can scan the car to check if the computer has stored a code on the problem you have, that will help pinpoint the trouble. Have you had the cel [check engine light] come on?

TAKE YOUR TIME, THINK IT OUT, DO IT RIGHT, DO IT ONCE!! original quote by me as far as I know. :rolleyes:
ALL MEMBERS PLEASE FILL IN USER PROFILES. DETAILS HELP OTHER MEMBERS HELP YOU .
pulsar86 is offline  
#5 (permalink) Old 02-04-2010, 03:10 PM
Newbie
 
Join Date: Feb 2010
Posts: 6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

I got the codes:
P0700 Trans Control Sys Malfunction
P0748 Pres Ctrl Sola. Circuit Electrical
P0700 Pending trans control system malfunction
macaluso624 is offline  
#6 (permalink) Old 02-04-2010, 11:10 PM
Veteran
 
Pacosworld's Avatar
 
Join Date: Feb 2009
Location: Urbana, IL
Posts: 1,033
Drives: 1990 VW Corrado SC 1.8L, 2005 Kia Spectra EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)

Default

Quote:
Originally Posted by macaluso624 View Post
I got the codes:
P0700 Trans Control Sys Malfunction
P0748 Pres Ctrl Sola. Circuit Electrical
P0700 Pending trans control system malfunction
P0748 VF Solenoid Valve Circuit - Open or short (GND)
You should have Powertrain warranty. My suggestion is take it to Kia Dealer for diagnosis. You might have an break in the wiring, a faulty valve in the transmission or a faulty ECM.

http://images.animelab.com/gallery/Akira/Images/akira022.jpg
Mike AKA Paco
For US Kia service info Kiatechinfo
Pacosworld is offline  
#7 (permalink) Old 02-08-2010, 10:48 PM
Member
 
Join Date: Mar 2009
Location: New Paltz, NY
Posts: 64
Drives: 2005 Spectra/Cerato
Gallery: 10
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Send a message via AIM to Bakwoods
Default

P0700 Trans Control Sys Malfunction = useless code from the PCM basically saying "Hey there's something wrong with the tranny" so that's out
P0748 Pres Ctrl Sola. Circuit Electrical = switch on the tranny is shorting out basically.
P0700 Pending trans control system malfunction = see above.

I really wish people would look on the KGIS site for information about their cars. It's REALLY helpful to know what your dealing with.


Though as the guy above said if it's under 100K then you can take it to the dealer and get it repaired FREE. It is under the powertrain warranty.
Bakwoods is offline  
#8 (permalink) Old 02-17-2010, 11:18 PM
Member
 
Join Date: Jul 2009
Location: Missouri
Posts: 29
Drives: 2006 Spectra
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

I had the same problem last year on my 06 spectra. Told the dealer about it. They took it in. He said there were no codes stored and they couldn't replicate the problem. He said that I would probably have to wait until something actually broke before they could do anything about it. Now that weather is cooler I haven't noticed it so much. I'm just waiting for something to break.
talltaylor is offline  
#9 (permalink) Old 07-12-2010, 02:15 AM
Newbie
 
Join Date: Nov 2009
Posts: 5
Drives: 2006 Kia Spectra5
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

I've got the EXACT same problem with my '06 S5 - when accelerating to get on the highway or passing the car downshifts, then shifts to O/D for a split second only to jerk really hard and slip back to third. It remains here until I either stop the car and turn off the engine for a few minutes or reset the computer by unplugging the neg. terminal. I got the 0700 and 0748 codes myself 2 months ago but I cleared them and they've yet to come back. BUT the problem still occurs - stuck in third gear. And nothign i do changes it - when this happens I can be at a stop light and shift into L, 2nd, D but the car remains in 3rd. It will respond to park, Neutral and Rev but is accompanied by a hard 'thud' when shifting into these gears during this problem.

I'd gladly take the car in for the warranty since it's only at 66k miles but i'm the second owner - according to Kia, yes the cars are covered for 100k miles BUT if you are the second owner of the vehicle that drops to only 12k miles! WTF?

Last edited by thisoneguy27; 07-12-2010 at 02:16 AM. Reason: forgot some information
thisoneguy27 is offline  
#10 (permalink) Old 11-15-2010, 09:17 AM
Newbie
 
Join Date: Nov 2010
Posts: 3
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

I have a 2006 spectra with some problem. went through the diagnoses that Aldata recomend but dont have a lap scope to do it correctly. i went ahead and put a control pressure selenoid in it and it didnt help. Im taking it in to a dealer to have them diagnose the problem. I'll let all of you know what I find out.
littlejim101 is offline  
Reply

  Kia Forum > KIA Models > Kia Cerato, Shuma & Spectra Forum > Cerato (2003 - 2008) & Spectra5 (2004)


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On