front windshield wipers not working - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 11-30-2009, 03:57 PM
Newbie
 
Join Date: Feb 2008
Posts: 6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default front windshield wipers not working

2005 Spectra 5 150,000 miles. Front wipers worked the day before now they don't work at all. They were left on overnight. Rear wiper works. Changed the relay for the front wiper, it didn't fix the problem. When I turn them on I don't hear anything either. Any ideas?
bosco2005 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 11-30-2009, 11:25 PM
Senior Member
 
Join Date: Jan 2009
Location: USA
Posts: 479
Drives: 08 Sonata LTD 3.3, 10 Dodge 1500 Hemi, 95 Taurus GL, 09 Sonata GLS 2.4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Quote:
Originally Posted by bosco2005 View Post
2005 Spectra 5 150,000 miles. Front wipers worked the day before now they don't work at all. They were left on overnight. Rear wiper works. Changed the relay for the front wiper, it didn't fix the problem. When I turn them on I don't hear anything either. Any ideas?
Try running the front windshield washer. If dead, then the fuse that serves both the front wipers and washer is blown. You should find a 15a fuse tagged 'Wiper' in the same box under the hood where you found the wiper relay. If the fuse is not blown (and assuming the new relay is good), then you either have a dead wiper motor or a bad switch. It never hurts to check the circuit connecter to the wiper motor.

Last edited by Ken99; 11-30-2009 at 11:53 PM.
Ken99 is offline  
#3 (permalink) Old 12-01-2009, 01:12 AM
Memorial Super Moderator
 
pulsar86's Avatar
 
Join Date: Jul 2009
Location: Sunshine Coast,Queensland, Australia
Posts: 2,863
Drives: 2005 Kia Cerato LD [2L petrol] manual, 1986 Nissan Pulsar hatch
Gallery: 3
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thumbs up

If the fuse checks out ok, try using jumper wires to give direct power to the wiper motor to check if it is still ok, being left on for a long time presumably in a garage with a dry screen might have burnt out the windings.

TAKE YOUR TIME, THINK IT OUT, DO IT RIGHT, DO IT ONCE!! original quote by me as far as I know. :rolleyes:
ALL MEMBERS PLEASE FILL IN USER PROFILES. DETAILS HELP OTHER MEMBERS HELP YOU .
pulsar86 is offline  
Reply

  Kia Forum > KIA Models > Kia Cerato, Shuma & Spectra Forum > Cerato (2003 - 2008) & Spectra5 (2004)

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On