URGENT - 2014 Kia Optima ABS Codes? Am I in danger? - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-09-2017, 09:04 PM Thread Starter
Newbie
 
Join Date: Jan 2017
Location: New York
Posts: 1
Drives: 2014 Kia Optima
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Exclamation URGENT - 2014 Kia Optima ABS Codes? Am I in danger?

Hey everyone!

So, the other day on my way to work I noticed that my car felt..wobbly for a brief period of time and weird. When breaking, the turning felt really.. off. So I stopped thinking maybe I had a flat tire. While stopping I swerved a little side to side and my steering felt weird.

So today I had the car checked, and I have three OBD2 Codes that popped up.

C1208
C1211
C1205

From what my friend is saying - the kit said "Wheel Sensor Invalid". I can't seem to find the codes online as they all show P codes.

Curious.. am I in any danger still driving? I have no lights on the dash as of current. But if it's the Wheel Sensors - would that effect my Power Steering or anything like that?

Also, I am currently at 36K Miles on the vehicle - would this be covered under warranty?

Skeith34 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-10-2017, 09:17 AM
Super Moderator
 
cobra259's Avatar
 
Join Date: Aug 2010
Location: Waterford MI
Posts: 4,370
Drives: 1995 Procharged Mustang Cobra -- 2006 Grand Cheorkee limted Hemi.
Gallery: 0
Mentioned: 20 Post(s)
Tagged: 0 Thread(s)
Quoted: 351 Post(s)

What was the weather like when this happened? Snow? Ice? Yes, it should be covered under your warranty. The only way it would not be covered is if you ran over something and broke an ABS sensor, if that was the case the ABS light would STAY on.
cobra259 is offline  
post #3 of 5 (permalink) Old 01-10-2017, 08:56 PM
Full Member
 
Join Date: Feb 2016
Location: St Paul MN
Posts: 190
Drives: 02 Sportage, 95 Trans Am, 05 Crossfire, 04 Venture
Gallery: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)

The ABS/Wheel Speed Sensor is a "Hall Effect" sensor that is usually located in the wheel hubs on front wheel drive vehicles and in the rear axle on some RWD vehicles.

I've heard it being called "ABS" sensor and I've also hear it being referred to as the "Wheel Speed Sensor".

Some vehicles that actually use this sensor as a "speed sensor" control the speedometer readout.

ABS (Automatic Brake Sensor) is the same type of sensor as the "Speed Sensor".

Now that that's out of the way, if the ABS sensor fails and you slide across a patch of ice, the ABS won't kick in. I prefer not to use ABS because it tends to get rather annoying. The brakes will automatically turn on and off so that someone in a quick situation does not lock up the brakes and create a traction issue. This is a cheap $10 - $20 sensor online. Do not pay any more than that. It is easy to replace yourself.

Your mention of the wheel feeling wobbly can be related to a failing wheel hub (wheel bearing) that has also caused the ABS sensor to fail. This should be covered under warranty. Don't take shit from a dealer. Stick it to em' hard.

Sent from my SM-G920V using Tapatalk
Markfothebeast is offline  
post #4 of 5 (permalink) Old 01-10-2017, 09:00 PM
Full Member
 
Join Date: Feb 2016
Location: St Paul MN
Posts: 190
Drives: 02 Sportage, 95 Trans Am, 05 Crossfire, 04 Venture
Gallery: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)

"C" codes I believe refer to chassis and suspension.

"P" I think is Powertrain but are definitely engine specific.

https://www.obd-codes.com/trouble_co...ssis-codes.php

Sent from my SM-G920V using Tapatalk
Markfothebeast is offline  
post #5 of 5 (permalink) Old 01-10-2017, 09:06 PM
Full Member
 
Join Date: Feb 2016
Location: St Paul MN
Posts: 190
Drives: 02 Sportage, 95 Trans Am, 05 Crossfire, 04 Venture
Gallery: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)

With some vehicles the "C" codes and transmission related codes do not show a "Check Engine Light". You may have felt a wobbly feeling because you did slide.

Sent from my SM-G920V using Tapatalk
Markfothebeast is offline  
Reply

  Kia Forum > KIA Models > Kia Magentis & Optima Forum > 4G (2011+) Optima



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On