Kia Forum - View Profile: ron1004

ron1004 ron1004 is offline

Super Moderator

  Visitor Messages

Showing Visitor Messages 1 to 8 of 8
  1. ScandiHooligan
    07-16-2015 08:26 AM - permalink
    ScandiHooligan
    Ref: July 27, 2009@6:49am - 2004 Kia Rio - "VERY Slow Acceleration After Reaching Operating Temp".
    I'm trying to help my son-inlaw sort out a very similar issue with his Kia. In this post you referenced the Kia Tech Website:

    "Take a look at the KiaTech web site (see my sig for link) for diagrams showing the exact location of these components and also descriptions on how to do a basic test of the MAF measuring its output voltage".

    I've tried to find it, but it's been 6 years, so I'm sure your link is long gone. Would you mind providing it again? Thanks in advance!
  2. DarrenPEI
    04-11-2015 04:54 PM - permalink
    DarrenPEI
    Thanks for the info Ron! Love Loti .
    Beauty car.
  3. DarrenPEI
    03-17-2015 02:32 PM - permalink
    DarrenPEI
    Hi Ron , I notice you have a real rarity with your Kia Elan. Memory tells me that the Elan of the 90's had an Isuzu engine. I am just curious if Kia placed a Kia engine in the final Elans
    ( such as yours ) , or if it is an Isuzu engine? In any event , you have a very desirable car
    IMO.
    Cheers,
    Darren
  4. panmike
    07-30-2014 03:50 PM - permalink
    panmike
    Hi, Ron. PanMike here. I see you've been around the block a long time here on the Forum. I have been having many of the same codes on my 2002 Kia Rio ever since I bought it 5 months ago. I have noticed on the forum many people talking about check the grounds when having a lot of codes. Do you know where to point me to clean, tighten, or whatever I need to do with the grounds, and where are they?
    Thanks in advance. Mike (PanMike)
  5. Fury
    03-16-2013 10:14 AM - permalink
    Fury
    Hi, can you also move my thread to a better forum? Thanks.

    http://www.kia-forums.com/3g-2011-ri...ion-radio.html
  6. 06Rio_FW
    03-06-2012 02:16 AM - permalink
    06Rio_FW
    Joe @ Brandon Distributing says the RF wheel isn't compatable with the Rio. Do you know anyone that has installed it on there Rio?. I asked him about Item #: 250-1483 and that is the one he says isn't compatible. Is that the model you have? How does it mount to the steering wheel?
  7. 06Rio_FW
    03-03-2012 12:04 AM - permalink
    06Rio_FW
    I'm looking to install cruise control on my 06 Rio. I've seen you posting about using the RF wheel switch. Can you send me a pic of your installation? Most of the kits I've found come with the left control that gets mounted into the steering column. My steering wheel will block the view of this mount. How do I get the kit without that control? Any help would be appreciated. Thx.
  8. HiroboFreak
    09-17-2011 07:55 AM - permalink
    HiroboFreak
    I am.
    I'm on the freak too but my main hangout is Australian R/C Helicopters Online (Dennis)

  About Me

  • About ron1004
    Location
    Louisville, KY
    Interests
    Cars, Bikes, Computer, electronics, RC helicopter & cars
    Vehicle(s) That You Own
    Kia Elan
    Occupation
    Engineer (power plant)
  • Signature
    Quality and not quantity counts.

    Sig image is 500X100 at 11.7 kb

  Statistics

Total Posts
Visitor Messages
General Information
  • Join Date: 06-29-2005
  • Referrals: 4

  Friends

Showing Friends 1 to 9 of 9

  Garage

    2000 Kia Elan
    Kia Elan

  Mentions

07-06-2015
09:47 AM - ron1004 mentioned Galf in post AC causes overheating when not moving.
...uld now agree with Galf. You need to replace...
07-02-2015
03:57 PM - ron1004 mentioned jetech00001 in post
06-15-2015
06:44 PM - ron1004 mentioned conwelpic in post KIA Water Feature
... in that photo. conwelpic suggested that the d...
05-22-2015
06:55 AM - ron1004 mentioned Ceed3 in post engine revving up when accelerating
... accurate than what Ceed3 has suggested.
04-08-2015
11:24 AM - ron1004 mentioned KimPhoenix in post 2012 Kia Sorento shuts off while driving
KimPhoenix Duplicate posts an...
03-29-2015
09:22 AM - Migsse mentioned ron1004 in post Kia Shuma 1.8 GS Not able to start engine
ron1004 I got the car back o...
07:27 AM - ron1004 mentioned Migsse in post Kia Shuma 1.8 GS Not able to start engine
Migsse , thanks for the fee...
05:16 AM - Migsse mentioned ron1004 in post Kia Shuma 1.8 GS Not able to start engine
ron1004 In the end, the ECU...
03-26-2015
07:44 AM - ron1004 mentioned tshop in post 99 KIA Sporage wont rev over 1800
...iming remain. tshop, please fill in your...
03-20-2015
06:13 AM - ron1004 mentioned upyourkia in post Dave Scott Lift Kits
... time forum member upyourkia , I'm sure he'll be ...
03-17-2015
12:38 PM - ron1004 mentioned FvA1306 in post cambelt/timing belt broke of 3.5L V6 2004 Sorento
...or engine assy?? FvA1306 please fill in your ...
06:20 AM - ron1004 mentioned cobra259 in post cambelt/timing belt broke of 3.5L V6 2004 Sorento
...V6 2004 engine? PM cobra259 he will most certain...
03-10-2015
07:07 AM - ron1004 mentioned nstoolman1 in post 2005 Kia Sorento will crank but not fire
... mechanic. Follow nstoolman1 advice above.
03-06-2015
10:07 AM - ron1004 mentioned Noahzark in post Totally LOST...ripped off by Kia and their fake warranty.
I believe the OP, Noahzark, has conceded that h...
02-26-2015
02:06 PM - ron1004 mentioned Loyale 2.7 Turbo in post MY 2004 Kia Sedona Work Van Maintennance Thread
... one of the ways. Loyale 2.7 Turbo posted a method of c...
02-24-2015
05:57 AM - kville kia mentioned ron1004 in post 2005 Kia Sorento will crank but not fire
...fuel & spark.... As ron1004 & cmar mentioned a t...
01-19-2015
11:52 AM - kville kia mentioned ron1004 in post Multiple random misfires
ron1004 Not sure if OP has ...
01-01-2015
05:56 AM - Migsse mentioned ron1004 in post Kia Shuma 1.8 GS Not able to start engine
...anks for the info. ron1004 The manager actually...
06-20-2014
12:23 PM - PLP mentioned ron1004 in post
04-15-2014
05:36 PM - AG Jeff mentioned ron1004 in post

  Thread Tags

No results to display...

  Quotes

07-28-2015
03:58 PM - ron1004 quoted hawkcruiser in post Rondo 2011 accessories
I recently traded my 2011 rondo ...
06:30 AM - ron1004 quoted li1308238914 in post Deleted Posts
06:28 AM - ron1004 quoted li1308238914 in post Deleted Posts
07-23-2015
12:01 PM - ron1004 quoted Chillpilly in post Engine computer failure
Quick update - I am still with...
07-17-2015
03:53 PM - ron1004 quoted jetech00001 in post
07-16-2015
08:41 PM - Loyale 2.7 Turbo quoted ron1004 in post Oil check comes on while idling after 5-10 mins driving
The oil pressure could be lo...
01:41 PM - ron1004 quoted super20 in post 2003 Sorento Won't Start Following Huge Project
you had better also understa...
11:48 AM - ron1004 quoted Chillpilly in post Engine computer failure
Thank you for you responses. I ...
07-15-2015
09:55 PM - ron1004 quoted nstoolman1 in post 2003 Sorento Won't Start Following Huge Project
Speak for yourself. I did it tw...
09:52 PM - ron1004 quoted Chillpilly in post Engine computer failure
Has anyone else experienced an ...
07-14-2015
02:11 PM - ron1004 quoted jetech00001 in post
09:15 AM - ron1004 quoted rhandwor in post 2003 Sorento Won't Start Following Huge Project
It appears the crank pulley i...
07-13-2015
07:27 AM - ron1004 quoted KBBGeorge in post 2003 Sorento Won't Start Following Huge Project
Okay gents. What I'm hearing ...
07-12-2015
05:46 PM - ron1004 quoted Jeff.G in post Stranded... Mech says TBS, but when it dies it doesn't start...
The codes are only areas th...
01:05 PM - ron1004 quoted mwilson0463 in post 2003 Sorento Won't Start Following Huge Project
It almost sounds like the timing...
07-11-2015
01:55 PM - mason123 quoted ron1004 in post sedona 58plate brake lights
The brake light switch contr...
01:27 PM - ron1004 quoted mason123 in post sedona 58plate brake lights
how do you mean? The brake...
12:06 PM - mason123 quoted ron1004 in post sedona 58plate brake lights
Seeing as the high level lig...
08:27 AM - mason123 quoted ron1004 in post sedona 58plate brake lights
What year/model is that? ...
07-10-2015
10:26 AM - ron1004 quoted helenamey@webmail.co.za in post Picanto 2004 LX 1.1 Sometimes will not start
I have a Picanto 2004 LX 1.1 When I try and ...