Kia Forum - View Profile: ron1004

ron1004 ron1004 is offline

Super Moderator

  Visitor Messages

Showing Visitor Messages 1 to 10 of 10
  1. ed122329
    01-03-2016 05:30 PM - permalink
    ed122329
    Hi do you still have your elan? I have a 01 sephia and I'm trunk to find a computer of a elan to put in my sephia and maybe the intake manifold but can't find anything on this car really on the Web nj usa
  2. Sam Witwicky
    11-16-2015 09:57 AM - permalink
    Sam Witwicky
    Hello!
    If you remember, I created the thread about a OBD-II monitoring device)
    Here is the link:
    http://www.kia-forums.com/do-yoursel...ml#post1237345
    So, you were interested. And so I send you the link to our Kickstarter campaign.
    https://www.kickstarter.com/projects...ce/description

    We would be glad to see you as our backer))) Every support will be appreciated.

    Thank you very much!
  3. ScandiHooligan
    07-16-2015 09:26 AM - permalink
    ScandiHooligan
    Ref: July 27, 2009@6:49am - 2004 Kia Rio - "VERY Slow Acceleration After Reaching Operating Temp".
    I'm trying to help my son-inlaw sort out a very similar issue with his Kia. In this post you referenced the Kia Tech Website:

    "Take a look at the KiaTech web site (see my sig for link) for diagrams showing the exact location of these components and also descriptions on how to do a basic test of the MAF measuring its output voltage".

    I've tried to find it, but it's been 6 years, so I'm sure your link is long gone. Would you mind providing it again? Thanks in advance!
  4. DarrenPEI
    04-11-2015 05:54 PM - permalink
    DarrenPEI
    Thanks for the info Ron! Love Loti .
    Beauty car.
  5. DarrenPEI
    03-17-2015 03:32 PM - permalink
    DarrenPEI
    Hi Ron , I notice you have a real rarity with your Kia Elan. Memory tells me that the Elan of the 90's had an Isuzu engine. I am just curious if Kia placed a Kia engine in the final Elans
    ( such as yours ) , or if it is an Isuzu engine? In any event , you have a very desirable car
    IMO.
    Cheers,
    Darren
  6. panmike
    07-30-2014 04:50 PM - permalink
    panmike
    Hi, Ron. PanMike here. I see you've been around the block a long time here on the Forum. I have been having many of the same codes on my 2002 Kia Rio ever since I bought it 5 months ago. I have noticed on the forum many people talking about check the grounds when having a lot of codes. Do you know where to point me to clean, tighten, or whatever I need to do with the grounds, and where are they?
    Thanks in advance. Mike (PanMike)
  7. Fury
    03-16-2013 11:14 AM - permalink
    Fury
    Hi, can you also move my thread to a better forum? Thanks.

    http://www.kia-forums.com/3g-2011-ri...ion-radio.html
  8. 06Rio_FW
    03-06-2012 03:16 AM - permalink
    06Rio_FW
    Joe @ Brandon Distributing says the RF wheel isn't compatable with the Rio. Do you know anyone that has installed it on there Rio?. I asked him about Item #: 250-1483 and that is the one he says isn't compatible. Is that the model you have? How does it mount to the steering wheel?
  9. 06Rio_FW
    03-03-2012 01:04 AM - permalink
    06Rio_FW
    I'm looking to install cruise control on my 06 Rio. I've seen you posting about using the RF wheel switch. Can you send me a pic of your installation? Most of the kits I've found come with the left control that gets mounted into the steering column. My steering wheel will block the view of this mount. How do I get the kit without that control? Any help would be appreciated. Thx.
  10. HiroboFreak
    09-17-2011 08:55 AM - permalink
    HiroboFreak
    I am.
    I'm on the freak too but my main hangout is Australian R/C Helicopters Online (Dennis)

  About Me

  • About ron1004
    Location
    Louisville, KY
    Interests
    Cars, Bikes, Computer, electronics, RC helicopter & cars
    Vehicle(s) That You Own
    Kia Elan
    Occupation
    Engineer (power plant)
  • Signature
    Quality and not quantity counts.

    Sig image is 500X100 at 11.7 kb

  Statistics

Total Posts
Visitor Messages
General Information
  • Join Date: 06-30-2005
  • Referrals: 4

  Friends

Showing Friends 1 to 10 of 10

  Garage

    2000 Kia Elan
    Kia Elan

  Mentions

02-08-2016
11:05 AM - PLP mentioned ron1004 in post
01-28-2016
01:47 PM - ron1004 mentioned Diode Dynamics in post Chatroom: Interior LED Mood Lighting
...r for these LED's. Diode Dynamics Diode Dynamics ...
01-13-2016
07:50 AM - ron1004 mentioned Ltdv8 in post 99 kia sportage engine swap
... Cheers, Chris Ltdv8 IP address puts him ...
01-12-2016
08:14 AM - ron1004 mentioned night.fox in post Optima won't start, smoke from hood
...em. I agree with night.fox , an auto electricia...
01-09-2016
12:27 PM - ron1004 mentioned jetech00001 in post New Member Introduction
...orum. Please head jetech00001 comment above. Plea...
12-28-2015
06:27 PM - ron1004 mentioned gaylen606 in post Mass Air Flow Sensor
...put high, or low. gaylen606 Please update your p...
12-15-2015
10:53 PM - ron1004 mentioned ap0c552 in post Bye bye Rio
ap0c552 , you are welcome t...
11-29-2015
11:57 AM - ron1004 mentioned cobra259 in post 2011 Sedona Oil Filter
...d on your VIN. PM cobra259 and I bet he'll give...
11-20-2015
09:27 PM - ron1004 mentioned shapeshade in post Engine troubles
Good advice from shapeshade , compression test, ...
11-16-2015
03:54 PM - ron1004 mentioned DavesSpectra in post 2011 sportage dies while driving, no start, no crank
...for your model. PM DavesSpectra , he has a good onli...
09-27-2015
09:52 AM - ron1004 mentioned Galf in post Sedona 2007 2.9 elm 327 obd queries 20 pin pinout?
... in the above link, Galf has it working. Let...
09-04-2015
01:40 PM - ron1004 mentioned DavesSpectra in post '02 Spectra - P0171 - Lean at Bank 1
... One of our MOD's DavesSpectra which as you can gat...
09-02-2015
02:03 PM - ron1004 mentioned cobra259 in post Aftermarket oil filter for Sedona 2011 - 2012 (3.5)
...PM to our moderator cobra259 and he might be able...
07-06-2015
10:47 AM - ron1004 mentioned Galf in post AC causes overheating when not moving.
...uld now agree with Galf. You need to replace...
07-02-2015
04:57 PM - ron1004 mentioned jetech00001 in post
06-15-2015
07:44 PM - ron1004 mentioned conwelpic in post KIA Water Feature
... in that photo. conwelpic suggested that the d...
05-22-2015
07:55 AM - ron1004 mentioned Ceed3 in post engine revving up when accelerating
... accurate than what Ceed3 has suggested.
04-08-2015
12:24 PM - ron1004 mentioned KimPhoenix in post 2012 Kia Sorento shuts off while driving
KimPhoenix Duplicate posts an...
03-29-2015
10:22 AM - Migsse mentioned ron1004 in post Kia Shuma 1.8 GS Not able to start engine
ron1004 I got the car back o...
08:27 AM - ron1004 mentioned Migsse in post Kia Shuma 1.8 GS Not able to start engine
Migsse , thanks for the fee...

  Thread Tags

No results to display...

  Quotes

02-14-2016
05:24 PM - ron1004 quoted administrator in post
02-13-2016
11:21 AM - ron1004 quoted administrator in post
02-12-2016
11:19 PM - ron1004 quoted hecky66 in post rear camera
I have a 2015 kia sorento my...
04:15 PM - ron1004 quoted administrator in post
02-11-2016
06:23 PM - ron1004 quoted PLP in post
06:04 PM - ron1004 quoted administrator in post
02-09-2016
11:43 AM - ron1004 quoted administrator in post
09:45 AM - administrator quoted ron1004 in post
02-08-2016
02:01 PM - ron1004 quoted administrator in post
11:26 AM - ron1004 quoted thiscarismine in post Kia Rio rear offside light cluster glass
Hi all. I'm new here, so forgive m...
08:11 AM - ron1004 quoted Markfothebeast in post Kia Fuel Ratings Adjustment Program
My lil' Kia 2.0L 4-cylinder SUV get...
02-05-2016
04:44 PM - ron1004 quoted administrator in post
01:23 PM - ron1004 quoted Ricardo Chile in post Language radio problems
This appears when I press the INFO...
09:48 AM - ron1004 quoted steveb5004 in post 2001 Sportage fuel issues? Maybe something else?
Thank you, I just updated my lo...
08:29 AM - ron1004 quoted steveb5004 in post 2001 Sportage fuel issues? Maybe something else?
I just bought a 2001 Sportage f...
06:04 AM - ron1004 quoted Ricardo Chile in post Language radio problems
I don't know what's the problem wi...
02-04-2016
06:31 PM - ron1004 quoted Ricardo Chile in post Language radio problems
Here they are I have tried mult...
05:31 PM - ron1004 quoted Ricardo Chile in post Language radio problems
Sorry, here comes a better picture...
02-03-2016
08:09 PM - ron1004 quoted WesBez7 in post Dealership charging $300 diagnostic fee and no issues found
Paragraphs. Makes for tireso...
02-02-2016
05:12 PM - ron1004 quoted Ben Thompson in post No Radio or Traffic information available
I have found that when I have the...