Intermittent left front dome light - Kia Forum
 1Likes
  • 1 Post By Strongbunch
 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-21-2017, 05:21 PM Thread Starter
Newbie
 
Join Date: Apr 2013
Location: Utah, USA
Posts: 9
Drives: 2013 Kia Rio Sedan EX Auto w/convenience pkg
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Intermittent left front dome light

Iím hoping one of you may have an idea whatís going on with my 2013 Kia Rio Sedan EX Auto w/convenience pkg. Intermittently, my left (driverís) front dome light will not come on when a door is opened. The right front dome light always does, but the left is intermittent. I would suspect the door switch, but is doesnít matter which of the four doors I open when itís acting up Ė the light will not come on Ė on the left side. Note: I can press the lens, and the map light in that position will always come one. I donít know if there are two bulbs in there/on each side for these two features, or if it only uses one bulb per side for both dome and map. Also, I donít know if itís a single or dual filament bulb. It has been doing this randomly for several months now. I canít tell if itís related to temperature, or vibration, or whatÖ As it goes, when I have time to stop by the dealer, it happens to be always working. Any ideas? Would this still be covered under my 5/60,000 warranty, or should I dig into it? Thanks.

Strongbunch is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 05-13-2017, 09:08 PM
Newbie
 
Join Date: May 2017
Location: Ontario, Canada
Posts: 1
Drives: 2014 Rio5 SX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

I wonder whether you got it fixed? It happened to mine on the passenger side but I fixed it and it's rather easy. Its just replacing 1 diode behind the housing.
bravoxray is offline  
post #3 of 3 (permalink) Old 05-19-2017, 11:31 AM Thread Starter
Newbie
 
Join Date: Apr 2013
Location: Utah, USA
Posts: 9
Drives: 2013 Kia Rio Sedan EX Auto w/convenience pkg
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Thanks for the tip bravoxray.
I removed the two lens covers, and the screw behind each. Then, the dome light assembly can be unplugged/removed. There is an axial lead general purpose rectifier on the back side of each light. The lead appears to be spot welded to a metal plate on each end (rather than soldered). The connections were good on both ends, and the diode/rectifier checked good with a meter. However, based on advice from bravoxray above, I cut the leads from the old and removed. I soldered in a new one, replacing the OEM 1N4007 diode. So far, it is working great. It has only been two days. But, in the past, it would have acted up several times by now. I think itís fixed! Iíve never this this type of intermittent failure in a diode Ė they have either worked, or not. It must be an intermittent failure in the diodeís internal p-n junction.
Thank again bravoxray. I know itís a little thing, but it was driving me crazy! I found myself looking up and checking for that light Ė day or night.
jetech00001 likes this.
Strongbunch is offline  
Reply

  Kia Forum > KIA Models > Kia Rio Forum > 3G 2012+ Rio



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On