Where's the drain plug for the radiator? - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 9 (permalink) Old 01-07-2013, 04:07 PM Thread Starter
Newbie
 
Join Date: Dec 2012
Posts: 6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default Where's the drain plug for the radiator?

Anyone know where the drain plug for the radiator is? I looked at the diagram on kiatechinfo and still can't find it.
Thanks!
~clover is offline  
Sponsored Links
Advertisement
 
post #2 of 9 (permalink) Old 01-07-2013, 04:30 PM
Super Moderator
 
cobra259's Avatar
 
Join Date: Aug 2010
Location: Waterford MI
Posts: 3,233
Drives: 1995 Procharged Mustang Cobra -- 2006 Grand Cheorkee limted Hemi.
Gallery: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 106 Post(s)

Default

Right side bottom.
cobra259 is offline  
post #3 of 9 (permalink) Old 01-07-2013, 05:50 PM
Veteran
 
GregsKia's Avatar
 
Join Date: Feb 2011
Location: Manistee, Michigan, USA
Posts: 1,117
Drives: 06 Sedona EX, 06 Sedona LX, 07 Optima EX 2.4L, 13 Optima Hybrid LX, 09 Amanti Premium, 14 Forte EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Garage

Default

If it is like any other Hyundai/Kia radiator I have seen, the drain plug will be GREEN.

Vehicles: 06 Sedona EX, 237k miles---06 Sedona LX, 258k miles---06 Sedona LX, 189k miles---07 Optima EX 2.4L, 96k miles---13 Optima Hybrid LX, 19k miles---09 Amanti, 88k miles---14 Forte EX 2.0L, Prem+Tech, 89k miles---11 Sportage EX AWD 2.4L, Prem+Nav, 88k miles
GregsKia is offline  
post #4 of 9 (permalink) Old 01-08-2013, 02:06 AM
Newbie
 
Join Date: Jan 2013
Posts: 4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

it is like any other Hyundai/Kia radiator I have seen
mileojule is offline  
post #5 of 9 (permalink) Old 01-08-2013, 01:19 PM Thread Starter
Newbie
 
Join Date: Dec 2012
Posts: 6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

Thanks guys. After looking for a while I finally found it... it's hidden up under that plastic cover on the bottom of the car. Now the problem is I can't get the stupid cover off. Any special secret to getting it off? I took all the retaining clips off and all the bolts but one... there's one bolt in the middle towards the front that will NOT come off. It just keeps spinning and spinning. I looked on kiatechinfo and all it says is to remove the clips and bolts... should be simple enough but for some reason one bolt just keeps spinning. I got some pictures of it... I tried gripping on to the other side of the bolt and it still won't come off.


Other side of bolt from above the undercarriage splash guard thing:


Last edited by ~clover; 01-08-2013 at 05:07 PM.
~clover is offline  
post #6 of 9 (permalink) Old 01-09-2013, 08:19 AM
Member
 
Join Date: Nov 2012
Location: Kansas City Mo
Posts: 30
Drives: 2013 Sportage SX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

It would better serve you to (carefully)disconnect the lower radiator hose to drain the system
twajfk is offline  
post #7 of 9 (permalink) Old 01-09-2013, 04:41 PM
Newbie
 
Join Date: Dec 2012
Location: Florida USA
Posts: 9
Drives: 2012 KIA Sportage EX AWD Premium Pkg, 2001 Ford F150
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Looks like you've got a broken kep nut.

Need to put vise grip locking pliers on the nut (cylinder).
With plenty of penetrating oil then try unscrewing.

You may need to vise grip the other end too.

Might not be safe to apply heat or a drill.
cbclark4 is offline  
post #8 of 9 (permalink) Old 01-10-2013, 12:48 PM Thread Starter
Newbie
 
Join Date: Dec 2012
Posts: 6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

Thanks everyone, off to go try get it off now!
~clover is offline  
post #9 of 9 (permalink) Old 01-11-2013, 08:20 PM
Senior Member
 
Join Date: Mar 2011
Location: VA
Posts: 445
Gallery: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)

Default

Quote:
Originally Posted by twajfk View Post
It would better serve you to (carefully)disconnect the lower radiator hose to drain the system
The winnah! Quick and dirty. Make sure engine is STONE COLD before opening the cooling system.

2011 Sportage EX
FWD Auto Silver/Black
1saxman is offline  
Sponsored Links
Advertisement
 
Reply

  Kia Forum > KIA Models > Kia Sportage Forum > 3G 2011+ Sportage

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On