Stuck in Park Position - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-27-2012, 04:26 PM
Member
 
Join Date: Aug 2010
Location: Louisiana, United States
Posts: 26
Drives: 2011 Kia Sportage EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default Stuck in Park Position

While I was out of town yesterday, my sportage was stuck in park. This had happened on several occasions before. Usually I would turn off my car, wait a few seconds, turn the car back on and everything would be okay. Every time it happened, I noticed two lights were lit up on the dashboard (traction control). So after turning my car off several times, I still couldnt get it out of park. My friend found the Shift-lock release on the shifter panel and I was able to release the shifter into the reverse position. It happened again twice after...so annoying.

When I scheduled an appointment for tomorrow, the dealership knew exactly what I was talking about. Sounds like it is a common problem for some owners. Have any of you had issues?
ColePL is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-27-2012, 10:46 PM
Full Member
 
KiaMonster's Avatar
 
Join Date: Apr 2011
Location: Princeton NJ
Posts: 105
Drives: 2011 Kia Sportage EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Yes, the ESC and DBC lights. Its caused by the faulty brake light switch that's triggered by the brake pedal. I had the same issue after owning my Sportage a few weeks. It happened twice and before I called the dealer I tried something strange that actually worked and the problem has never returned.

I put my foot behind the brake pedal and then gave a quick pull of the pedal towards me. Thinking if the switch was stuck, this would help push it in and fix it. It worked for me. People can laugh if they want, but again, it worked for me. One year later and no problem.
KiaMonster is offline  
#3 (permalink) Old 03-27-2012, 11:27 PM
Member
 
Join Date: Aug 2010
Location: Louisiana, United States
Posts: 26
Drives: 2011 Kia Sportage EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default Pedal

Wow after a few weeks of owning your sportage? That sucks but lucky you that you were able to fix it yourself. I tried yesterday exactly what you described but it wouldn't budge. I still love my sportage even after this minor flaw. I hope it wont become a regular occurance after the dealer fixes it. Im also getting my air conditioner checked because of the noise it started making. Lol the dealership is going to hate me.
ColePL is offline  
#4 (permalink) Old 03-28-2012, 12:42 AM
Veteran
 
Join Date: Mar 2010
Location: Southwest PA
Posts: 1,409
Drives: 10 Optima LX, 07 Rondo EX, 89 Chevy C1500
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)

Default

Yup, you need a brake switch.
spongebob218 is offline  
Reply

  Kia Forum > KIA Models > Kia Sportage Forum > 3G 2011+ Sportage

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On