P2106 Trouble Code - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 07-31-2009, 07:39 PM
Newbie
 
Join Date: Jul 2009
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default P2106 Trouble Code

When I start my car first thing in the morning, "Check Engine" light turns on and I have limited acceleration power. I turn on and off my engine for about 20 times and drive on the parking lot for about 10-15 minutes and that problem goes away right after I turn on my engine one more time. After that my car is able to accelerate without any problem and check engine light turns off itself after 30-40 minutes. That whole thing happens only once or twice a week and only when I start the engine first thing in the morning. Scanner tells me "P2106 Throttle actuator control system - Forced Limited Power." Does anybody know what is the problem?
KiaOptima2007 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-31-2009, 08:09 PM
Senior Member
 
Join Date: Sep 2008
Location: Ontario Canada
Posts: 408
Drives: 2006 Sportage
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

There is an updated throttle body assembly and an ecu upgrade. The throttle body MUST be replaced before the ecu upgrade is done. Take it to the dealer.
ESKORT27 is offline  
#3 (permalink) Old 08-01-2009, 06:12 AM
Senior Member
 
Join Date: Nov 2008
Posts: 241
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

ECM sets DTC P2106 to indicate ETC (Electronic Throttle Control)system malfunction has occurred and engine is in Limp-Home mode. The ECM reduces engine torque by 25% of normal value after setting the DTC, as an Emergency Operation(Limp-Home)mode.

If it's still under warranty there shouldn't be any cost.
If not, it's a crapshoot, but I'd take it to the dealer, or a well equipped shop that has diagnostic equipment. They will be better equipped to isolate the problem area.

Never tried it on the Kia, but next time it occurs, disconnect the negative battery for 30 seconds or so to see if it clears the history and returns to normal operation. If it does, it's only a short term fix, so better get it repaired.
turbonut is offline  
Reply

  Kia Forum > KIA Models > Kia Magentis & Optima Forum > 3G (2006.5+) Magentis & Optima


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On