2008 Optima check engine light on 3 times already! - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-16-2008, 11:05 AM
Newbie
 
Join Date: Aug 2008
Posts: 2
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Unhappy 2008 Optima check engine light on 3 times already!

Have a brand new 2008 Optima. Less than 3 months old and check engine light has comes on 3 times already. First 2 times was diagnosed as a small emission system leak due to gas cap not being tight. Third time not diagnosed yet, but suspect the same problem. Have a new gas cap on order from dealer. If this does not solve problem, then I will suspect that there is something wrong with the sensor. Anyone else having this problem??

Thanks in advance.
osageave is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-19-2008, 12:28 PM
Veteran
 
kiaracer's Avatar
 
Join Date: Nov 2005
Location: Pittsboro, NC
Posts: 1,252
Drives: 2000 Kia Sephia LS, 1998 Kia Sportage 4x4, 2002 Kia Sportage 4x4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)

Send a message via AIM to kiaracer Send a message via MSN to kiaracer Send a message via Yahoo to kiaracer
Default

i'm a service tech at a kia dealership and this seems to be a common problem with the 2008 optimas. if it does it after you put the new gas cap in take it to the dealer and tell them you want them to do an evap. system leak test and this will pin point the problem. most of the time a "very small leak" or "small leak" codes will be the gas cap but that doesn't rule out the possibility that there's something else wrong. make sure you turn the gas cap until it clicks.

"One who is slack in his work is brother to one who destroys."
kiaracer is offline  
#3 (permalink) Old 09-08-2008, 08:07 PM
Newbie
 
Join Date: May 2008
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Unhappy

I have the exact same problem. Been to the dealer 2 times in 4 days with the check engine light problem. Dealer reset codes both times and stated that it shows the same code indicating loose gas cap / evaporative leak. I know for sure that the cap was not loose. Dealer replaced gas cap today at my urging to try and see if it was the problem. Car has 5400 miles on it. Dealer stated that they have seen this problem a lot and that there should be a recall to repair the problem.
Dealer said that they had to test drive car to test for re-occurence (45 minutes and 2/10 miles worth according to odometer). I'm not real happy with my dealership and the way they handle my problems. I bought (2) 2008 optimas at one time. You would think they would see how much money you spent with them and treat you with a little respect.
gtpony is offline  
#4 (permalink) Old 09-10-2008, 10:47 PM
Veteran
 
kiaracer's Avatar
 
Join Date: Nov 2005
Location: Pittsboro, NC
Posts: 1,252
Drives: 2000 Kia Sephia LS, 1998 Kia Sportage 4x4, 2002 Kia Sportage 4x4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)

Send a message via AIM to kiaracer Send a message via MSN to kiaracer Send a message via Yahoo to kiaracer
Default

it has been a common problem with the new optimas. i haven't called the tech line to see if kia is aware of this issue yet or not (i would imagine they are....you'd be surprised at what they know) but the next time an optima comes in with this issue i'll give them a call and see what they say about it. i would advise if anyone has this problem to tell them you would like the gas cap tested to see if it really is a faulty gas cap. kia service departments have a gas cap tester to test kia gas caps to see if they are leaking or not. if they are leaking the replacement should be covered under warranty.

"One who is slack in his work is brother to one who destroys."
kiaracer is offline  
#5 (permalink) Old 09-14-2008, 07:46 PM
Newbie
 
Join Date: Aug 2008
Posts: 21
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Check your filler necks where the caps go on, seen a few with a deformed opening, not allowing the cap to seal.
koreatech is offline  
#6 (permalink) Old 09-17-2008, 11:18 AM
Administrator
 
administrator's Avatar
 
Join Date: May 2006
Posts: 1,240
Drives: Kia Spectra
Gallery: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Garage

Default

Quote:
Originally Posted by gtpony View Post
I have the exact same problem. Been to the dealer 2 times in 4 days with the check engine light problem. Dealer reset codes both times and stated that it shows the same code indicating loose gas cap / evaporative leak. I know for sure that the cap was not loose. Dealer replaced gas cap today at my urging to try and see if it was the problem. Car has 5400 miles on it. Dealer stated that they have seen this problem a lot and that there should be a recall to repair the problem.
Dealer said that they had to test drive car to test for re-occurence (45 minutes and 2/10 miles worth according to odometer). I'm not real happy with my dealership and the way they handle my problems. I bought (2) 2008 optimas at one time. You would think they would see how much money you spent with them and treat you with a little respect.
I suggested you contact Kia Consumer Affairs directly and they should be able to help resolve your issue. Kia Consumer Affairs direct # is 1-888-333-4KIA (4542).
administrator is offline  
#7 (permalink) Old 09-20-2008, 12:00 AM
Veteran
 
kiaracer's Avatar
 
Join Date: Nov 2005
Location: Pittsboro, NC
Posts: 1,252
Drives: 2000 Kia Sephia LS, 1998 Kia Sportage 4x4, 2002 Kia Sportage 4x4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)

Send a message via AIM to kiaracer Send a message via MSN to kiaracer Send a message via Yahoo to kiaracer
Default

i had another one of these come in this morning and i tested the gas cap and it failed the test. kia must have got a bad batch of gas caps for the optimas. i've also had the issue with the borrego but it's only happened once with the borrego so far...it just possible that whoever filled the tank up with gas didn't click the cap to make sure it was tight.

"One who is slack in his work is brother to one who destroys."
kiaracer is offline  
#8 (permalink) Old 09-20-2008, 10:29 AM
Newbie
 
Join Date: Aug 2008
Posts: 2
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

After 4 trips to the dealer, it looks like the problem has finally been solved. Dealer replaced "canister close valve" and stated that they were able to reproduce problem by playing with this valve. My guess is that this valve had a small leak and that is what produced the error code for the "small leak." At least it was covered by my warranty and I did get a new gas cap also.

Thanks to all who responded. Hope this helps anyone else who may have this problem in the future.
osageave is offline  
#9 (permalink) Old 11-01-2008, 07:04 PM
Member
 
Join Date: Nov 2008
Location: Hickory
Posts: 52
Drives: 96' kia sephia
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

My moms 08 has been on like 8 times, and it was the gas cap that was messed up, now that it has a good new one on it(for the 8th time this year) it hasn't been on since. I would check that first.
scooter2 is offline  
Reply

  Kia Forum > KIA Models > Kia Magentis & Optima Forum > 3G (2006.5+) Magentis & Optima

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On