Kia Forum - View Profile: 1fastkia

1fastkia 1fastkia is offline

Super Moderator

  Visitor Messages

Showing Visitor Messages 1 to 10 of 12
  1. chiefbrand
    08-30-2013 10:16 AM - permalink
    chiefbrand
    hi I'm new to the forum. my dome light doesn't work on any settings for a kia spectra ex 2004.5, bulb, fuses, wiring harness all fine. how do I take door sensor for doom light apart to check for problems. any help would be greatly appreciated chiefbrand
  2. 1fastkia
    11-19-2012 01:06 PM - permalink
    1fastkia
    Do not know the sedona, but check out www.kiatechinfo.com its free to sign up and find your shop manual.
    You have to use internet explorer or you get errors.
  3. Guy10596
    11-18-2012 09:13 AM - permalink
    Guy10596
    I am trying to change the tiimng belt on my sedona but i dont see a timing mark for the crank shaft ?
  4. Denford
    09-06-2012 10:56 AM - permalink
    Denford
    Hie and How are you? I have a small challenge, I recently did an engine overhaul on a KIA MAGENTIS 2005 engine Nr G4JP4121878 Automatic Transmission, The car Starts and it idles high when the filter is not on and when i put the air filter it shuts off. i have changed the Crank shaft sensor, cleaned the idle speed actuator. what could be the problem. PLEASE HELP
  5. Carjunky
    06-01-2012 04:48 AM - permalink
    Carjunky
    Hi! I have a 1997 sephia with 1.8 dohc fuel inj. ! I need to replace my valve stem seals ! I have looked at the spring compressors to remove them but the tools i see are for ohv or older style engines ! I am trying to do this with the head on the car !
  6. gdaryl333
    05-09-2012 10:14 AM - permalink
    gdaryl333
    Hello there,
    Sorry to bother you, but I am at my wits end. I have a 2005 Kia Rio. I need another engine for it. I know that the engines are going for $1500 or more for used ones. My question is: Is there a Hyundia A6D engine that will bolt onto the trans? I understand I might have to change a few things ie intake, cpu? But thats ok. My main thing is the block to trans fit and not spending $1500 when I could be spending $500. Any help would be great. Thanks Daryl
  7. 010Forte
    04-01-2012 09:22 AM - permalink
    010Forte
    Hey, I'm new to the forum stuff but wanted to know, since your name is 1fastkia, and I'm in search of performance parts for my Forte 2.0 if you could help me out. I'd really appreciate it. I've already gotten the basic stuff like cold air intake and exhaust taken care of and a turbo set up lined up, but other than that, I'm clueless as to where to look. ANY info you might be willing to share would be greatly appreciated. Thanks.
    -Kris
  8. KILL MY KIA
    03-23-2012 12:29 PM - permalink
    KILL MY KIA
    Hi i am brand new to this forum, hope im doin it right. I have a 2000 Kia Sephia, replaced manual 5 sp transmission 1 1/2 years ago, also replaced clutch, recently i had to replace clutch master cylinder, my car shifts smooth, tranny feel great, but the problem is, it seems to heat up somewhere near the clutch, badly, i have to pull over and let it cool, and it smells like oil coated clutch or burning clutch, or both, also when it gets that hot, it loses power and brakes get spungy, i think cause system is so darn hot underneath. We have bled system 3 times, so frustrated, can someone please, please help me get my car fixed. PLEASE ANY IDEAS !!!!!
  9. KILL MY KIA
    03-23-2012 12:15 PM - permalink
    KILL MY KIA
    im brand new to this forum, hope im doin it right. I have a 2000 Kia Sephia, replaced manual 5 sp transmission 1 1/2 years ago, also replaced clutch, recently i had to replace clutch master cylinder, my car shifts smooth, tranny feel great, but the problem is, it seems to heat up somewhere near the clutch, badly, i have to pull over and let it cool, and it smells like oil coated clutch or burning clutch, or both, also when it gets that hot, it loses power and brakes get spungy, i think cause system is so darn hot underneath. We have bled system 3 times, so frustrated, can someone please, please help me get my car fixed. :-(
  10. Peter K
    12-24-2011 05:14 PM - permalink
    Peter K
    How are you doin' ! As I said,both low beams went out together. Fuses are good, ground from fuse block looked good,but cleaned anyway. battery is new wich could raise questions since bulbs blew after battery was replaced. Any Ideas?

  About Me

  • About 1fastkia
    Location
    Vermont
    Vehicle(s) That You Own
    08 Sportage, 87 Mazda RX-7
    Occupation
    Powder Coating Operator
  • Signature
    08 Kia Sportage
    07 Saturn Aura
    87 Mazda RX-7
    Working on a 07 RX-8

    The Old
    99 Sephia, 01 Spectra, 05 Spectra

  Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 02-02-2014 09:38 AM
  • Join Date: 11-30-2004
  • Referrals: 0

  Friends

Showing Friends 1 to 4 of 4

  Mentions

No results to display...

  Thread Tags

No results to display...

  Quotes

03-12-2014
06:50 PM - Loyale 2.7 Turbo quoted 1fastkia in post Engine Valve Timing Interference - Confirmed NON-INTERFERENCE engine
... The engine blocks on 2002...
02:09 PM - kiaracer quoted 1fastkia in post Engine Valve Timing Interference - Confirmed NON-INTERFERENCE engine
So because it never happened ...