Trans noise in 07 rio - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 11-12-2012, 05:34 PM
Newbie
 
Join Date: Nov 2012
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default Trans noise in 07 rio

I have an 07 rio with an automatic transmission. It has a "gear" noise. It drives and shifts fine. The noise happens only when the car is rolling, It doesn't even have to be under power and is louder when the car isn't in a hard pull. It is like gears are rubbing together. It is more of a chatter but not really "grinding". The fluid level in the trany is good. Anybody experienced this before?
Thanks,
Steve
KiaRiver is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 11-30-2012, 04:16 PM
Member
 
Join Date: Jan 2012
Location: ChicagoLand, IL
Posts: 64
Drives: 2010 KIA Rio LX Midnight Black.. CAI.. 6000k HID..
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

i have some sort of rattling noise when its rolling, and right when i hit the gas but then it goes away. thought it was the heat shield hitting the firewall, fixed it (ironically it WAS broken) but that wasnt it. bringing it in under warranty next week!
Bmak18 is offline  
Reply

  Kia Forum > KIA Models > Kia Rio Forum > 2G (2006 - 2010) Rio & Rio5


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On