Idle Issues - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 01-16-2013, 06:55 PM Thread Starter
Newbie
 
Join Date: Aug 2012
Posts: 9
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Unhappy Idle Issues

Hello guy's,

I have a 2005 Kia sportage lx with a 2.7L V6 engine, I'm having some idling issue's with my sportage and would like to see if you guy's could give me some input on what the problem could be, My sportage idles at 4000 rpms when driving and cruising and when coming to a complete stop it idles really low and seems like it wants to cut off. So far i have replaced 2 oxygen sensors, Throttle sensor and the idle control actuator and it still idles really weird....I'm fresh out of ideas and solutions, Any thought's or idea's what the problem could really be.....Thanks's
charmer37 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 01-16-2013, 07:22 PM
Veteran
 
Join Date: May 2012
Location: Australia
Posts: 1,236
Drives: Cerato S Hatch Auto
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

Default

It wouldn't be "idling" while you were cruising, would it? It should be doing about 2500 RPM on the highway in top gear. Assuming it's an auto, maybe it's performing so badly that you're in 3rd or 4th gear instead of top gear?

Catalytic converter can get blocked and cause poor performance.
Wry 'Cuda is offline  
post #3 of 6 (permalink) Old 01-16-2013, 09:57 PM Thread Starter
Newbie
 
Join Date: Aug 2012
Posts: 9
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

Hello wry'Cuda Thanks for responding...It idles high when driving at a normal speed in 1st gear but it should shift like you mention at 2500 rpm's, its a automatic transmission. When i take off from a complete stop my rpm's go up to 4000 rpm's before it shifts to 2nd gear, When stopping at a stop light the idles jumps down really low like it wants to cut off. I always warm up my sportage to normal temperatures before i drive it...I'll see whats up with the cat converter...Thanks for the advice.
charmer37 is offline  
post #4 of 6 (permalink) Old 01-16-2013, 11:18 PM
Veteran
 
Join Date: May 2012
Location: Australia
Posts: 1,236
Drives: Cerato S Hatch Auto
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

Default

4000 RPM before shifting to 2nd gear is normal; if you keep going, does it get to top gear?

Idling generally means engine turning over slowly with the car stopped and transmission in neutral (about 700 RPM). There might be a misunderstanding in terms here.

When you come to a halt, the transmission should be "idling" in 1st gear and there might be a slight drop in RPM compared to neutral, but not enough to nearly stall the engine.

Not sure of your location and local temperature, but it is not usually worthwhile to warm the engine for more than 30 seconds. Unless there's a load on the engine, it will take a long time to warm to full operating temp.
Wry 'Cuda is offline  
post #5 of 6 (permalink) Old 01-23-2013, 06:42 AM
Senior Member
 
tysinbad's Avatar
 
Join Date: Feb 2009
Location: Ipswich Queensland Australia
Posts: 284
Drives: 06 Sportage/08 Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)

Default

a high idle like that can also mean an air leak, whee the engine is sucking in extra after the MAF (mass airflow meter).


06 V6 EXL Sportage - NGM Stage 1 Sniper Charged
UNICHIP ECU, 2.5" Exhaust, Custom Headers, Modified Intake
tysinbad is offline  
post #6 of 6 (permalink) Old 01-23-2013, 05:16 PM
Veteran
 
GregsKia's Avatar
 
Join Date: Feb 2011
Location: Manistee, Michigan, USA
Posts: 1,118
Drives: Two-06 Sedona LX,06 Sedona EX,07 Optima EX, 13 Optima HEV LX, 09 Amanti, 14 Forte EX, 11 Sportage EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Garage

Default

Most idle issues result from some sort of vacuum leak.

Vehicles: 06 Sedona EX, 237k miles---06 Sedona LX, 258k miles---06 Sedona LX, 189k miles---07 Optima EX 2.4L, 96k miles---13 Optima Hybrid LX, 19k miles---09 Amanti, 88k miles---14 Forte EX 2.0L, Prem+Tech, 89k miles---11 Sportage EX AWD 2.4L, Prem+Nav, 88k miles
GregsKia is offline  
Sponsored Links
Advertisement
 
Reply

  Kia Forum > KIA Models > Kia Sportage Forum > 2G (2005-2010) Sportage

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On