07 sportage reverse light issue - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 07-26-2011, 11:11 AM
Newbie
 
Join Date: Jul 2011
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage

Thread Starter (Thread Starter)
Default 07 sportage reverse light issue

my father-in-law has a 2007 kia sportage w/ manual transmission, he has informed me that the reverse lights will no longer come on when placed in reverse. he has checked the fuse and the bulbs, but both are fine. i did some reading on here and seems that the issue could be the switch that engages the lights when put in reverse. is this a common issue? or would replacing it just be a stab in the dark? thanks TJ
07sportagenm is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-26-2011, 02:31 PM
Full Member
 
Join Date: Jul 2010
Posts: 95
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

after checking the bulbs and fuses, the next thing I would check is the switch.
herkie is offline  
#3 (permalink) Old 08-06-2011, 12:28 AM
Newbie
 
Join Date: Aug 2011
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

I got the same sh!t in a 2009 model. I have to squeazze it for working. Bad quality, man
c_a_porras is offline  
Reply

  Kia Forum > KIA Models > Kia Sportage Forum > 2G (2005-2010) Sportage


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On