2000 Kia Sephia LS - P1624/P0743/P0455 - Need help! - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 09-06-2011, 11:59 PM
Newbie
 
Join Date: Sep 2011
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default 2000 Kia Sephia LS - P1624/P0743/P0455 - Need help!

I just bought this kia sephia and it runs very well, but all of a sudden the O/D light came on and the check engine light came on. So I took it to autozone and had the codes ran and this is what I got back:

P0455 - EVAP emission system - leak detected - large leak
- faulty fuel cap
- leakage in emission system
- faulty vent solenoid

P1624 - Cooling fan relay circuit malfunction (low)
- open or short circuit condition
- poor electrical connection
- failed cooling fan low relay

P0743 - Torque converter clutch system circuit malfunction
- open or short circuit condition
- poor electrical condition
- failed torque converter clutch solenoid

I see the common statement appears to be electrical. The car shifts fine, does not wind out, I definitely feel it going through the gears ok. But I am definitely worried about it. Just not sure what to do from this point out. Any help or suggestions would be greatly appreciated. Thank you.
arrc is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 10-05-2011, 03:02 PM
Newbie
 
Join Date: Oct 2011
Location: E Tennessee
Posts: 12
Drives: 2001 Kia Sephia, 1995 BMW 325i
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

I had a transmission control module alarm in my BMW a couple of years ago. I cleared it by removing and re-inserting the three fuses that control it. I would suggest you look up which fuses/relays pertain to those components and pull the fuses for them and reset them before doing anything else. Seems fishy to me that it is all electrical and all at once with things seemingly working well.

Gerry
gsim is offline  
#3 (permalink) Old 10-05-2011, 03:21 PM
Super Moderator
 
1fastkia's Avatar
 
Join Date: Nov 2004
Location: Vermont
Posts: 6,103
Drives: 08 Sportage, 87 Mazda RX-7
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

Default

First one, start out by buying a new gas cap, the seal fails, causes a leak then throws this code. 5 dollar fix, worst case, still have the code.
BUT reset the ecu after you install it. Disconnect neg. terminal on battery, get in try and start it and turn on all acc. Reinstall battery cable, start it up.

Try this before you do anything though, could be a fluke code where something went out of spec.

2nd, is the cooling fan turning on? Check to see its operation.

3rd, I don't know much about transimmision lol.

08 Kia Sportage
07 Saturn Aura
87 Mazda RX-7
Working on a 07 RX-8

The Old
99 Sephia, 01 Spectra, 05 Spectra
1fastkia is offline  
Reply

  Kia Forum > KIA Models > Kia Sephia Forum > 2G (1998 - 2001) Sephia


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On