2000 Kia Sephia - Low Beams Not Working - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-31-2009, 07:50 PM Thread Starter
Newbie
 
Join Date: Oct 2009
Posts: 3
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default 2000 Kia Sephia - Low Beams Not Working

High beams do. Swapped the fuses around for the low and high beams (box under hood), still the same situation. I don't see any fuses in the fuse box located inside the car for the headlights.

Suggestions? Need new headlights/bulbs? If so, how do you change them out?

Thanks
riddlewh is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 10-31-2009, 10:39 PM
Veteran
 
kiaracer's Avatar
 
Join Date: Nov 2005
Location: Pittsboro, NC
Posts: 1,252
Drives: 2000 Kia Sephia LS, 1998 Kia Sportage 4x4, 2002 Kia Sportage 4x4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)

Send a message via AIM to kiaracer Send a message via MSN to kiaracer Send a message via Yahoo to kiaracer
Default

i would check the bulbs first before getting too deep into it. there are big caps on the back of the headlights that screw off to get to the bulb on each headlight. if you need new bulbs, the bulb type is a 9003.

"One who is slack in his work is brother to one who destroys."
kiaracer is offline  
post #3 of 4 (permalink) Old 11-01-2009, 06:39 AM Thread Starter
Newbie
 
Join Date: Oct 2009
Posts: 3
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

Thanks, could one bulb going out cause both lights to stop working or do you think both went out at the same time?
riddlewh is offline  
post #4 of 4 (permalink) Old 11-01-2009, 11:00 AM Thread Starter
Newbie
 
Join Date: Oct 2009
Posts: 3
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

I went to Advance Auto Parts and picked up a set of bulbs for $25, that did the trick. Thanks for your help.
riddlewh is offline  
Sponsored Links
Advertisement
 
Reply

  Kia Forum > KIA Models > Kia Sephia Forum > 2G (1998 - 2001) Sephia

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On