2000 Kia Spectra Sephia--turns over but won't start...please help!!! - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 05-11-2009, 06:11 PM
Newbie
 
Join Date: May 2009
Posts: 2
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Angry 2000 Kia Spectra Sephia--turns over but won't start...please help!!!

I would appreciate any help anyone can give me with this thing...I am at my wit's end trying to figure out what is wrong with it...We started out by replacing a headlight and a tail light that went out...The back tail light bulbs were full of water...Got rid of all the water...Bulb was extremely corroded...still don't know how in the world all that water got in there...thought everything was ok...put it back together after finally having to dig the bulb out...then started blowing fuses...don't know if we shorted something out or what...got fuses replaced...now won't start at all...turns over fine, but acts like it's not getting gas...when you spray ether into the air cleaner it will start, but then minute it's burned up, car cuts off...just doesn't get any gas...have checked all fuses, checked fuel pump relay and it's good...please if anyone has any suggestions, please email me at blkwidow35@yahoo.com....I would appreciate any advice I can get...as I am desperate to get this thing going!!! Thanks so much and take care everyone!!!
BettyBoop38 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-11-2009, 07:09 PM
Super Moderator
 
ron1004's Avatar
 
Join Date: Jun 2005
Location: Louisville, KY
Posts: 4,600
Drives: Kia Elan
Gallery: 13
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 49 Post(s)
Garage

Default

Welcome to the forum.

You have at least confirmed that it's a fuel delivery problem.
I would place a jumper on the DLC diagnostic plug in the engine compartment to force the fuel pump to run - if it runs then it confirms the fuel pump is OK and the problem is most likely with the fuel pump relay.
If the pump is running, then it's either a bad pump or fuel filter or fuel rail pressure regulator.

Try the KiaTech web site for more info on the DLC jumper arrangement and try a forum search.
http://www.kia-forums.com/gtsearch.p...art&sa=Go#1068

For service info register (free) with KiaTechInfo and click on 'Shop' on the left, and for elect schematics click on 'ETM'.

Quality and not quantity counts.

Sig image is 500X100 at 11.7 kb
ron1004 is offline  
#3 (permalink) Old 05-14-2009, 12:38 PM
Full Member
 
ShiKia's Avatar
 
Join Date: Oct 2006
Location: Four Corners of Arizona
Posts: 88
Drives: two 96 Kia Sephias, 1987 Subaru Hatchback,2004 Dodge SRT-4,2004 Dodge Neon,2004 Ford F-150,1986 Ford
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default Won't start

Your problem is that there is no fuel getting to your throttle. That tells me it's probably your fuel pump. It has to be or a loose wire thats not making the spark. Recheck those and you should be able to pin point the problem. Good luck!
ShiKia is offline  
Reply

  Kia Forum > KIA Models > Kia Sephia Forum > 2G (1998 - 2001) Sephia


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On