2001 Kia Sephia Speedometer - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-29-2009, 06:25 PM
Newbie
 
Join Date: Apr 2009
Location: SouthEast
Posts: 7
Drives: '00 Sephia
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default 2001 Kia Sephia Speedometer

Having some of the same trouble as others I've read about on this board.

Check engine light on. O/D light flashing.

At first the speedometer was not affected.

Changed the speed sensor. Cleared the error. Everything was back to normal.

About three days after that the speedometer dies, and my son said the car did not want to shift.

I double checked my work and found one of the sensor wires almost cut in half. (Did I do that on the first sensor change? Maybe...) Resoldered the wire, cleared the error. Everything was fine again.

This lasted, again , about three days. Now, it's back to light and no speedometer. A new development. When I decelerate, the speedometer jumps around wildly. I was thinking I had another short at the plug, but everything looks good all the way to the main bundle.

I cleared the error again and drove it a short distance. No lights, but no speedometer.

I've taken the speed sensor back out. I'm going to return it to Autozone for a swap out. (I've have several things from AZ lately, defect off the shelf.)

Anything else I should be looking for? (Sorry, I don't know how the read the check engine light code. Maybe someone can enlighten me.)

TIA!
Tinbendr is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-30-2009, 10:23 AM
Veteran
 
kiaracer's Avatar
 
Join Date: Nov 2005
Location: Pittsboro, NC
Posts: 1,252
Drives: 2000 Kia Sephia LS, 1998 Kia Sportage 4x4, 2002 Kia Sportage 4x4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)

Send a message via AIM to kiaracer Send a message via MSN to kiaracer Send a message via Yahoo to kiaracer
Default

drive the car to autozone and have them scan it for a code. it's free.

"One who is slack in his work is brother to one who destroys."
kiaracer is offline  
#3 (permalink) Old 05-03-2009, 03:55 PM
Newbie
 
Join Date: Apr 2009
Location: SouthEast
Posts: 7
Drives: '00 Sephia
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default

Replaced the sensor, again, and it lasted about two days.

Seems I might have a short.

About the error code; some vehicles flash from the dash lights. I didn't know it the Sephia would do the same thing.

I'm leaving now to take it to AZ to get the code read.
Tinbendr is offline  
#4 (permalink) Old 05-03-2009, 04:46 PM
Newbie
 
Join Date: Apr 2009
Location: SouthEast
Posts: 7
Drives: '00 Sephia
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default

Just got back.

It appears it's a transaxle error code and my AZ does not have reader to specifically read it.

Looks like I'll have to break down and take it in. Ugghhh!
Tinbendr is offline  
#5 (permalink) Old 05-04-2009, 07:35 PM
Newbie
 
Join Date: Apr 2009
Location: SouthEast
Posts: 7
Drives: '00 Sephia
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default

Well, I took the Sephia in this morning to a mechanic. (Heavy sigh)

It was the turbine speed sensor (under the airbox), not the vehicle speed sensor (rear top of the transaxle) that was bad. (That'll teach me to try and diagnosis without reading the error code )

Live and learn!
Tinbendr is offline  
#6 (permalink) Old 05-04-2009, 07:46 PM
Veteran
 
kiaracer's Avatar
 
Join Date: Nov 2005
Location: Pittsboro, NC
Posts: 1,252
Drives: 2000 Kia Sephia LS, 1998 Kia Sportage 4x4, 2002 Kia Sportage 4x4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)

Send a message via AIM to kiaracer Send a message via MSN to kiaracer Send a message via Yahoo to kiaracer
Default

you can guess all day long and you may or may not fix it. if you do fix it by guessing, you're either really good, psychic, or you just wasted a lot of money. always read the code if there is one. when there isn't a code is when it really becomes a job to figure it out.

"One who is slack in his work is brother to one who destroys."
kiaracer is offline  
#7 (permalink) Old 05-04-2009, 09:44 PM
Newbie
 
Join Date: Apr 2009
Location: SouthEast
Posts: 7
Drives: '00 Sephia
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default

Quote:
Originally Posted by kiaracer View Post
always read the code if there is one.
Amen!

In this case, I don't think of it as a waste. The VSS was very rough when turned by hand. I like to think I invested in preventative maintenance. (That's my story and I'm sticking to it!)

Thanks for listening to my sob story.
Tinbendr is offline  
#8 (permalink) Old 05-05-2009, 07:33 AM
Veteran
 
kiaracer's Avatar
 
Join Date: Nov 2005
Location: Pittsboro, NC
Posts: 1,252
Drives: 2000 Kia Sephia LS, 1998 Kia Sportage 4x4, 2002 Kia Sportage 4x4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)

Send a message via AIM to kiaracer Send a message via MSN to kiaracer Send a message via Yahoo to kiaracer
Default

my point i was trying to make was if you guess by throwing parts at it hoping to fix it, then that's wasting money. if you just happen to guess and replace one part and it happens to fix it, then you got lucky.

"One who is slack in his work is brother to one who destroys."
kiaracer is offline  
#9 (permalink) Old 04-07-2011, 04:33 PM
Newbie
 
Join Date: Jan 2005
Posts: 19
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Could you show me a pic where that Turbine Sensor is? AZ only shows a vehicle speed sensor for my '99 sephia.
Dano is offline  
Reply

  Kia Forum > KIA Models > Kia Sephia Forum > 2G (1998 - 2001) Sephia


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On