O/D light flashing + Check Engine? - Kia Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 07-14-2006, 08:13 PM
Newbie
 
Join Date: Jul 2006
Location: Tulsa, Oklahoma
Posts: 11
Drives: His: 2000 Sephia; Hers: 2003 Spectra LS
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default O/D light flashing + Check Engine?

My husband just called me from the road and reported that after gassing up, our dear 2000 Sephia displayed a check engine light and a flashing Overdrive light.

(We've gone through tightening the gas cap to make the check-engine light go away; we're old pros by now at tightening the cap until it clicks several times, so it's not gas fumes triggering it this time.)

I asked him to turn off the overdrive to see if there would be a change in the lights; the o/d did in fact disengage but the light continued to blink rather than stay on solid.

At the time of the call, he was about 20 miles from home; I told him to just drive it and we'll deal with it later. I'm not sure if our local dealership will be able to take it in tomorrow - their saturdays are usually booked full for weeks.

Anyone have this before? Any ideas on what the problem may be? Any guesses about the roadworthiness for a 120-mile drive on Sunday and taking it to a shop in OKC instead of Tulsa? (As unnecessary background: he works 5 days in OKC and then drives home to Tulsa on Fridays.)

Thanks for any input!

--Em
elfnow is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-14-2006, 08:18 PM
Newbie
 
Join Date: Jul 2006
Location: Tulsa, Oklahoma
Posts: 11
Drives: His: 2000 Sephia; Hers: 2003 Spectra LS
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default A quick update...

The car is safely in our garage now... upon return, my husband turned it off and then restarted the engine. The Check engine light is now off, but the o/d light is still blinking.

*weird*

--Em
elfnow is offline  
#3 (permalink) Old 07-14-2006, 08:25 PM
Newbie
 
Join Date: Jul 2006
Location: Tulsa, Oklahoma
Posts: 11
Drives: His: 2000 Sephia; Hers: 2003 Spectra LS
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

Apparently, the manual specifies it's an electrical problem with the transaxle.
elfnow is offline  
#4 (permalink) Old 07-15-2006, 12:49 AM
Newbie
 
Join Date: Jul 2006
Posts: 12
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

remove the positive battery cable for 3 minutes and reinstall it to see if it will reset the ecu
jeffgregory1 is offline  
#5 (permalink) Old 07-16-2006, 08:57 AM
Super Moderator
 
1fastkia's Avatar
 
Join Date: Nov 2004
Location: Vermont
Posts: 6,102
Drives: 08 Sportage, 87 Mazda RX-7
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)

Default

you must hit the brakes to clear all saved memory after you disconnect the battery to fully clear the ecu!

08 Kia Sportage
07 Saturn Aura
87 Mazda RX-7
Working on a 07 RX-8

The Old
99 Sephia, 01 Spectra, 05 Spectra
1fastkia is offline  
#6 (permalink) Old 07-16-2006, 09:59 AM
Newbie
 
Join Date: Jul 2006
Location: Tulsa, Oklahoma
Posts: 11
Drives: His: 2000 Sephia; Hers: 2003 Spectra LS
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Question Sorry, more girly questions...

OK, so I guess my big girly question here is:

Should I clear the ecu myself or should I take it to the dealership and pay them whatever they want to charge me to probably eventually tell me "oh it was just a code, we cleared it out" ?

I mean, heck, I'm all for disconnecting the battery and standing on the brakes - if there really is a problem, will the light just keep blinking? Or would I be masking something potentially hairy?

Sorry for the ... I want the best for the car, but I'd like to consider what's best for the budget, too. :dance:

--Em

(in the meantime, the local Hertz has provided my husband a lovely little Hyundai for a small fee...)
elfnow is offline  
#7 (permalink) Old 07-16-2006, 09:05 PM
Newbie
 
Join Date: Jul 2006
Location: Tulsa, Oklahoma
Posts: 11
Drives: His: 2000 Sephia; Hers: 2003 Spectra LS
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Talking Ok well that worked for now...

Figured I can't make it worse by resetting it... so I did, thanks for the tips for doing that.

I'll drive the thing around tomorrow a bit and see if the problem reoccurrs.

--Em

(note to self: green powder on battery should not be touched. Wear gloves next time. *chuckle*)
elfnow is offline  
#8 (permalink) Old 07-17-2006, 08:55 AM
Super Moderator
 
1fastkia's Avatar
 
Join Date: Nov 2004
Location: Vermont
Posts: 6,102
Drives: 08 Sportage, 87 Mazda RX-7
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)

Default

if you got green stuff on the battery its time to clean the terminals before it stops starting! or even replace the battery and clean the terminals.

08 Kia Sportage
07 Saturn Aura
87 Mazda RX-7
Working on a 07 RX-8

The Old
99 Sephia, 01 Spectra, 05 Spectra
1fastkia is offline  
#9 (permalink) Old 07-21-2006, 07:53 PM
Newbie
 
Join Date: Jul 2006
Location: Tulsa, Oklahoma
Posts: 11
Drives: His: 2000 Sephia; Hers: 2003 Spectra LS
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default Thanks!

It's been a week and the car is still giving no indication there was ever a problem. I'll look up the battery warranty - it's only like a year or so old, silly for it to be leaking H2SO4 already. Either way, thanks muchly for all the advice/help.

--Em
elfnow is offline  
#10 (permalink) Old 02-20-2008, 10:21 PM
Newbie
 
Join Date: Nov 2007
Posts: 3
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

my kia sephia 2000 a/t start to light the check engine and blinking the o/d, the codes are
# p1800 and # p1624
Enrique is offline  
Reply

  Kia Forum > KIA Models > Kia Sephia Forum > 2G (1998 - 2001) Sephia

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On