Four wheel drive won't engage - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 07-05-2012, 07:56 AM
Newbie
 
Join Date: Jun 2008
Location: Anchorage, Alaska
Posts: 3
Drives: 2007 Kia Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default Four wheel drive won't engage

I have an 07 sorento that I put in a ditch now the four wheel drive won't engage. The light comes on but the front wheels don't engage. I lifted the hood and I could hear the pump kick on. In two wheel it drives fine, but if I engage the four wheel drive it has a vibration at 45 mph and up. I live in Alaska so four wheel drive is a necessity in the winter. PLEASE HELP!!!!
csmasten is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-05-2012, 03:16 PM
Veteran
 
Join Date: Dec 2005
Location: Winchester, Calif
Posts: 1,874
Drives: 2003 S-10 Had an 03 LX 3.5 Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)

Default

Sometimes there is a vacuum hose that gets brittle and leaks or breaks. Find the pump and trace the hose(s) and see if they are intact. I don't own a 4x4 but I have read about this problem on here. HTH
nstoolman1 is offline  
#3 (permalink) Old 07-06-2012, 01:30 AM
Veteran
 
gee6's Avatar
 
Join Date: Jan 2006
Location: Rural Bedfordshire, UK.
Posts: 1,251
Drives: 08 2.5 CRDI Sorento Titan Auto
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)

Default

Quote:
Originally Posted by csmasten View Post
I lifted the hood and I could hear the pump kick on.
If a pipe is damaged, the pump will continue to run. If it stops, presume it has reached defined pressure and pipes are ok.

[The pump is pressurising (not a vacuum) a diaphragm INSIDE the diff casing which activates the diff side of the system. If the diaphragm/pipes are damaged the transfer case may activate, but the diff won't.]
gee6 is offline  
#4 (permalink) Old 07-06-2012, 02:26 AM
Veteran
 
Join Date: Dec 2005
Location: Winchester, Calif
Posts: 1,874
Drives: 2003 S-10 Had an 03 LX 3.5 Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)

Default

My bad. I prefaced I did not own one. I guess my main point is to check for leaks. I bow to the more experienced among us.
nstoolman1 is offline  
#5 (permalink) Old 09-27-2012, 07:16 AM
Newbie
 
Join Date: Jun 2008
Location: Anchorage, Alaska
Posts: 3
Drives: 2007 Kia Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default Checked the vacuum

Ok so I just checked the vacuum pump. I turned the ignition to the on position, turned the switch to 4wd, and the pump came on and I heard a klunk then the pump kicked off. It still will not engage the front wheels. Last winter I put it straight into a ditch and and I tryed to get it to rock back and forth out of the ditch the four wheel drive worked when I first tried to get unstuck but it was high centered. I then put it in 4 low and I could feel it engage but it was really stuck. After that I haven't had fwd at all. While it was in 4 low after engaging the light on the dash would start to flash. I was putting in it drive then reverse then drive then reverse alot. Could this be a computer problem.
I took the car to the dealer to have it checked out, then had it for three days and told me it might be the front diff, but they didn't know. While I was there they asked if I had had my 30,000 mile service done, I said I hadn't yet, so they asked if I wanted it done. I didn't have the $500.00 for it that day so I told them to give me a couple of days then I could get it done. They told me since it had 33,000 miles on it and I didn't get the 30,000 mile service done that the warranty was now voided on my drivetrain and to fix the car I would be paying $5000.00. Frickkin dealership. I told them not to send anything in for testing til I got the service done. Can anyone please help it's gettting cold which means snow soon.
csmasten is offline  
#6 (permalink) Old 09-30-2012, 07:04 PM
Newbie
 
Join Date: Jun 2008
Location: Anchorage, Alaska
Posts: 3
Drives: 2007 Kia Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default More info

I did so more looking under the car. When I put the car in four wheel drive there is a klonk and the air pump turns on for a few seconds. When it drives forward the front prop shaft turns when it's disengaged the front prop shaft doesn't turn. When I jack up one front tire and engage four wheel drive the tire still turns. I really need help I can't figure this out.
csmasten is offline  
#7 (permalink) Old 09-30-2012, 08:13 PM
Senior Member
 
Join Date: Sep 2008
Location: Sunshine Coast
Posts: 425
Drives: 2003 Sorento, 98 Sportage, 1944 Jeep
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

Default

If the pump pumps up and then stops, then the diaphragm sounds like it is intact, if the transfer case klonks, and the front prop shaft turns when you flip the switch, and drive, the transfer case sounds OK.
Sounds like you may have damaged the dog clutch in the front diff.
Try turning a front wheel with both front wheels off the ground and 4x4 dialed up, the other wheel should turn in the opposite direction if the locking mechanism is working. The other wheel won't turn if it isn't.

That would explain the lack of 4x4. Unfortunately if that is the case the front diff will need to come out and apart to fix it.
cmar is offline  
#8 (permalink) Old 12-26-2012, 09:08 PM
Full Member
 
timosorento's Avatar
 
Join Date: Jun 2007
Location: West Des Moines IA
Posts: 78
Drives: 2004 kia sorento 3.5 v6 gas
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

I actually might tear into my Sorento and replace the actuator this weekend. Does anyone know if you can just remove the lower ball joints and pop the axles out of the diff without taking the axle nut off and removing it from the hub?
timosorento is offline  
Reply

  Kia Forum > KIA Models > Kia Sorento Forum > 2003-2010 Sorento Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On