2007 Kia Sorento LX - No Reverse Lights - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-31-2011, 04:55 PM
Newbie
 
Join Date: Aug 2011
Location: Louisville, KY
Posts: 15
Drives: 2007 Kia Sorento LX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default 2007 Kia Sorento LX - No Reverse Lights

We just bought a 2007 Kia Sorento LX a couple weeks ago from out of state. Today I noticed that the reverse lights are not working. I pulled them out and checked the bulbs and everything was fine. Any idea of what could be wrong with this? I was hoping just a fuse, but I dont even see a reverse light fuse in the manual. I see "EXT Taillight, Turn Signal Light", as well as "Turn Lamp, Turn Signal Light", "Stoplight", Room Lamp etc, but nothing about a reverse light. Thanks

Last edited by Necrosaro420; 08-31-2011 at 06:02 PM.
Necrosaro420 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-31-2011, 06:55 PM
Veteran
 
Pacosworld's Avatar
 
Join Date: Feb 2009
Location: Urbana, IL
Posts: 1,030
Drives: 1990 VW Corrado SC 1.8L, 2005 Kia Spectra EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)

Default

Quote:
Originally Posted by Necrosaro420 View Post
We just bought a 2007 Kia Sorento LX a couple weeks ago from out of state. Today I noticed that the reverse lights are not working. I pulled them out and checked the bulbs and everything was fine. Any idea of what could be wrong with this? I was hoping just a fuse, but I dont even see a reverse light fuse in the manual. I see "EXT Taillight, Turn Signal Light", as well as "Turn Lamp, Turn Signal Light", "Stoplight", Room Lamp etc, but nothing about a reverse light. Thanks
Okay, if the reverse bulbs are okay, you should check if you're getting power to the sockets. The only fuse for the backup lights is the METER fuse. I believe it powers other parts so if it was blown, you would see other issues. There is a relay for backup lamps on the passenger side by the glove box. You should check for power there too. If the relay is good, then you probably have a wiring issue.

http://images.animelab.com/gallery/Akira/Images/akira022.jpg
Mike AKA Paco
For US Kia service info Kiatechinfo
Pacosworld is offline  
#3 (permalink) Old 08-31-2011, 11:09 PM
Newbie
 
Join Date: Aug 2011
Location: Louisville, KY
Posts: 15
Drives: 2007 Kia Sorento LX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default

Quote:
Originally Posted by Pacosworld View Post
Okay, if the reverse bulbs are okay, you should check if you're getting power to the sockets. The only fuse for the backup lights is the METER fuse. I believe it powers other parts so if it was blown, you would see other issues. There is a relay for backup lamps on the passenger side by the glove box. You should check for power there too. If the relay is good, then you probably have a wiring issue.
Thanks, I will have to check that out tomorrow. Should I just use a multimeter with the relay? If so, what should the output be? Have not yet checked the meter fuse. Thanks!
Necrosaro420 is offline  
#4 (permalink) Old 08-31-2011, 11:29 PM
Newbie
 
Join Date: Aug 2011
Location: Louisville, KY
Posts: 15
Drives: 2007 Kia Sorento LX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default

Ok I checked out the meter fuse real quick and it was good. Im not sure about the relay switch. I looked real quick and it appears they will have 4 and 5 connections on that, and not totally sure which connectors to check with a multimeter
Necrosaro420 is offline  
Reply

  Kia Forum > KIA Models > Kia Sorento Forum > 2003-2010 Sorento Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On