Cd Player Error - Kia Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 05-11-2010, 08:07 PM
Newbie
 
Join Date: May 2010
Location: Queensland, Australia
Posts: 4
Drives: Kia Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Question Cd Player Error

Bought a 2004 Kia Sorento EX MY05 a week ago and really pleased with it. However, all of a sudden, it will not play our CDs. Just displays 'ERR' and won't play them. Have tried a whole range of CDs (copies and originals) but doesn't like any of them! The radio is still working (thank goodness as can't stand no music in the car).

Has this happened to anyone else and, if so, did you find a solution? PS: Tried running a CD laser cleaning disc through but it just seemed to get stuck after a period of time and so finally had to eject it, therefore, problem still unsolved.

Hubby phoned a KIA dealer who said it would be costly to have it in for diagnosis and that it would be expensive and time-consuming to order parts if something needed replacing. He suggested purchasing a new stereo altogether and having it fitted in the original one's place. Having exhausted all our budget on the car itself, this is not an option for us at present, so just hoping someone out there might have some more positive advice?!

Any words of wisdom would be greatly appreciated! Thanks.
Spoons is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 05-11-2010, 09:07 PM
Memorial Super Moderator
 
pulsar86's Avatar
 
Join Date: Jul 2009
Location: Sunshine Coast,Queensland, Australia
Posts: 2,863
Drives: 2005 Kia Cerato LD [2L petrol] manual, 1986 Nissan Pulsar hatch
Gallery: 3
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thumbs up

Welcome to the KIA forums. One thing you might like to try is to remove the negative battery cable from the battery for a couple of minutes and then reconnect , it may just happen to reset the CD player. Just make sure you know your code to put into the radio when the battery is reconnected otherwise you will be locked out of the radio by the security system.

TAKE YOUR TIME, THINK IT OUT, DO IT RIGHT, DO IT ONCE!! original quote by me as far as I know. :rolleyes:
ALL MEMBERS PLEASE FILL IN USER PROFILES. DETAILS HELP OTHER MEMBERS HELP YOU .
pulsar86 is offline  
#3 (permalink) Old 05-11-2010, 09:10 PM
Newbie
 
Join Date: May 2010
Location: Queensland, Australia
Posts: 4
Drives: Kia Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

Quote:
Originally Posted by pulsar86 View Post
Welcome to the KIA forums. One thing you might like to try is to remove the negative battery cable from the battery for a couple of minutes and then reconnect , it may just happen to reset the CD player. Just make sure you know your code to put into the radio when the battery is reconnected otherwise you will be locked out of the radio by the security system.
Thank you. Will try and find out the code and give it a go!
Spoons is offline  
#4 (permalink) Old 05-11-2010, 09:13 PM
Senior Member
 
Join Date: Sep 2008
Location: Ontario Canada
Posts: 408
Drives: 2006 Sportage
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

If the negative battery cable idea doesn't work, try to remove the radio and actually unplug the connector at the back. I have had a few radios act up, i tried the cable idea on it and no luck, removed the connector and it reset, but one other one i had, the battery cable disconnect worked. FYI
ESKORT27 is offline  
#5 (permalink) Old 05-11-2010, 09:25 PM
Newbie
 
Join Date: May 2010
Location: Queensland, Australia
Posts: 4
Drives: Kia Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

Quote:
Originally Posted by pulsar86 View Post
Welcome to the KIA forums. One thing you might like to try is to remove the negative battery cable from the battery for a couple of minutes and then reconnect , it may just happen to reset the CD player. Just make sure you know your code to put into the radio when the battery is reconnected otherwise you will be locked out of the radio by the security system.
Have just had a look through the owner's manual and the only code mentioned is a key code? Would this also be the code for the stereo? Thanks.
Spoons is offline  
#6 (permalink) Old 05-11-2010, 09:27 PM
Newbie
 
Join Date: May 2010
Location: Queensland, Australia
Posts: 4
Drives: Kia Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

Quote:
Originally Posted by ESKORT27 View Post
If the negative battery cable idea doesn't work, try to remove the radio and actually unplug the connector at the back. I have had a few radios act up, i tried the cable idea on it and no luck, removed the connector and it reset, but one other one i had, the battery cable disconnect worked. FYI
Thanks for that. Gives us another option if the battery cable disconnection doesn't work. Appreciate your reply.
Spoons is offline  
#7 (permalink) Old 05-12-2010, 08:23 AM
Newbie
 
Join Date: May 2010
Location: Heartland USA
Posts: 11
Drives: 05 Kia Sorento Lx 4x4 5spd.auto 99 Chrysler 300m 95 Ford Bronco
Gallery: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Quote:
Originally Posted by pulsar86 View Post
Welcome to the KIA forums. One thing you might like to try is to remove the negative battery cable from the battery for a couple of minutes and then reconnect , it may just happen to reset the CD player. Just make sure you know your code to put into the radio when the battery is reconnected otherwise you will be locked out of the radio by the security system.
oops...After reading some post on here about transmissions not downshifting, I just disconnected/reconnected my battery last night for 10 minutes. Was worried that I might have to reprogram my presets but to my surprise they remained intact and the radio works fine ...however the clock didn't, no biggie there. Didnt even think about the security system,(stoopid newbie!) hopefully no issues will arise. Btw transmission seems to be behaving somewhat better(much thanks to this forum) and hopefully will correct itself in the next 250 miles.
kiacruz is offline  
#8 (permalink) Old 05-12-2010, 11:43 AM
Senior Member
 
Join Date: Sep 2008
Location: Ontario Canada
Posts: 408
Drives: 2006 Sportage
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

disconnecting the battery will not harm anything. In all the KIA's I have worked on, the only ones that need a radio code is the early sportage. No other radio needs a security code. Well, maybe the new Sorento and Borrego and Amanti, but I have yet to have one out.
ESKORT27 is offline  
#9 (permalink) Old 05-13-2010, 12:35 AM
Memorial Super Moderator
 
pulsar86's Avatar
 
Join Date: Jul 2009
Location: Sunshine Coast,Queensland, Australia
Posts: 2,863
Drives: 2005 Kia Cerato LD [2L petrol] manual, 1986 Nissan Pulsar hatch
Gallery: 3
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Default

The Cerato/ Spectra need the four number code to work after the battery is disconnected, that is why I mentioned it just incase Sorentos are the same. It looks like the radio in the 05 Sorento doesn't require a code by the report from Kiacruz but could another 05 Sorento owner please let the forum know whether their radio requires security code after disconnecting battery, I would hate to have someone lock themself out of the radio if it does need one..

TAKE YOUR TIME, THINK IT OUT, DO IT RIGHT, DO IT ONCE!! original quote by me as far as I know. :rolleyes:
ALL MEMBERS PLEASE FILL IN USER PROFILES. DETAILS HELP OTHER MEMBERS HELP YOU .

Last edited by pulsar86; 05-13-2010 at 12:42 AM.
pulsar86 is offline  
#10 (permalink) Old 05-13-2010, 09:28 AM
Veteran
 
Join Date: Dec 2005
Location: Winchester, Calif
Posts: 1,861
Drives: 2003 S-10 Had an 03 LX 3.5 Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)

Default

My 03 LX does not if that helps.
nstoolman1 is offline  
Reply

  Kia Forum > KIA Models > Kia Sorento Forum > 2003-2010 Sorento Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On