Please Help Asap Re: Sorento Stuck In 4wd Low - Kia Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 02-15-2010, 07:00 PM
Newbie
 
Join Date: Feb 2010
Posts: 2
Drives: 2003 Kia Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default Please Help Asap Re: Sorento Stuck In 4wd Low

hi. i'm new here and here out of desperation.
hubby is on his way home in our 2003 kia sorento and says the suv is stuck in 4wd low. (we had snow/ice here today and he needed to use the 4wd.)
ive read to him the other posts ive found regarding similiar situations but nothing's helped so far.
please advise.
thank u in advance!
jaydensmom is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 02-15-2010, 08:21 PM
Full Member
 
Join Date: Sep 2009
Location: virginia,USA
Posts: 148
Drives: o7 Sorento 07 Camry,99 Pontiac
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

Default

Could be many things. Fill out your profile and give us as much info about the truck(mileage,auto or manual tranny,etc)as you can. First check this forum for all the posts regarding your problem. This forum is a great information source. Check all of your fuses. Did this just happen or has it happened before? Could be something simple, could be expensive. Good luck.
fiddlersridge is offline  
#3 (permalink) Old 02-15-2010, 08:32 PM
Newbie
 
Join Date: Feb 2010
Posts: 2
Drives: 2003 Kia Sorento
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Lightbulb Help!!!

Quote:
Originally Posted by fiddlersridge View Post
Could be many things. Fill out your profile and give us as much info about the truck(mileage,auto or manual tranny,etc)as you can. First check this forum for all the posts regarding your problem. This forum is a great information source. Check all of your fuses. Did this just happen or has it happened before? Could be something simple, could be expensive. Good luck.
It is a 2003 sorento with 146000 miles. we have never had this problem before. it is the 3.7L V6 automatic. what do the fuses have to do with the 4wd? the check engine light is on and so are both the 4wd hi and the 4wd low indicator lights!!

Last edited by jaydensmom; 02-15-2010 at 08:52 PM.
jaydensmom is offline  
#4 (permalink) Old 02-16-2010, 12:44 PM
Full Member
 
Join Date: Sep 2009
Location: virginia,USA
Posts: 148
Drives: o7 Sorento 07 Camry,99 Pontiac
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

Default

Fuse check because one might be blown and not providing the electrical power to the switch/tranfer case motor to move the transfer case out of 4wd low.If you can get it to a code reader(a little box that the computer in your truck tells the mechanic what is wrong), have a shop or parts place(Advance auto,autozone) and have your check engine light codes read. Alot of times it will tell you a code,like P3003, you look up the code here in this forum and it will tell you what is wrong. This will go along way to finding out what is wrong with your truck, Anyone else want to weigh in?Good Luck!!
fiddlersridge is offline  
#5 (permalink) Old 02-16-2010, 12:57 PM
Newbie
 
Join Date: Jan 2010
Location: Denver, Colorado
Posts: 18
Drives: 2010 Kia Soul, 1994 Ford Ranger
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

So let's get back to basic's. While vehicle is running put transmission in Neutral, hold brake pedal and then switch switch back to 2 wheel drive --- see if that does the trick, have have seen many of my customers not do these steps and you will not get it out of 4x4 unless you do (4 wheel low that is) -- see if this does the trick, if not may have issue with 4x4 module, bring to the dealer to confirm but that year has had issues with 4x4 module
WOOLLFF is offline  
#6 (permalink) Old 02-16-2010, 04:18 PM
Veteran
 
Join Date: Sep 2007
Location: Low Country East Coast USA
Posts: 2,876
Drives: 2010 SOUL + Auto (B2522),2010 Soul SPORT Limited Edition Stick (B2581)
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Quote:
Originally Posted by WOOLLFF View Post
So let's get back to basic's. While vehicle is running put transmission in Neutral, hold brake pedal and then switch switch back to 2 wheel drive --- see if that does the trick, have have seen many of my customers not do these steps and you will not get it out of 4x4 unless you do (4 wheel low that is) -- see if this does the trick, if not may have issue with 4x4 module, bring to the dealer to confirm but that year has had issues with 4x4 module
Very good first step advise. Once out if this did the trick then rethink how you and hubby think 4LO works. Very few situations will you need 4LO. And if you use it wrong (many infact do) this is just what you get it to do JAM in LO. 4LO is in no way like AWD. Niether is 4HI but not as picky if you do it.
04SorentoLX is offline  
#7 (permalink) Old 02-16-2010, 05:26 PM
Veteran
 
pistnbroke's Avatar
 
Join Date: May 2007
Location: UK a sad cold place
Posts: 1,047
Drives: 2006 3.5 Sorento 4x4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

stop ...foot on brake....neutral ....move switch ...wait 10 seconds listen for clunk...

Am a bit concerned you have the check light on ..if above does not work it dealer time .

if no go get under and look if you have ripped the wiring off the hi low motor ..its a bit like a wiper motor ....
pistnbroke is offline  
#8 (permalink) Old 03-12-2010, 01:47 PM
Newbie
 
Join Date: Mar 2010
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Quote:
Originally Posted by jaydensmom View Post
hi. i'm new here and here out of desperation.
hubby is on his way home in our 2003 kia sorento and says the suv is stuck in 4wd low. (we had snow/ice here today and he needed to use the 4wd.)
ive read to him the other posts ive found regarding similiar situations but nothing's helped so far.
please advise.
thank u in advance!
Hi, I have an 2004 2.5 sx. I too had this problem. For a quick fix to get you back on the road is to disconnect the battery for a few minutes, and re connect. This will reset the solenoid, you are back in 4 high. Then its a replacment solenloid. Hope this helps.
kiabutler is offline  
#9 (permalink) Old 03-12-2010, 08:15 PM
Veteran
 
pistnbroke's Avatar
 
Join Date: May 2007
Location: UK a sad cold place
Posts: 1,047
Drives: 2006 3.5 Sorento 4x4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Its actually an electric motor that moves a lever to change the gears in the transfer box Not a solenoid ....as stated must be stationary. neutral and give it time to move. Its only 2hi to 4 hi you can do on the fly ( air pump engages front axle)
pistnbroke is offline  
#10 (permalink) Old 01-21-2011, 10:52 AM
Newbie
 
Join Date: Apr 2007
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Default Fixed!

I had this problem last night. Couldn't get out of 4WD low. Who ever posted to pull the parking break, put it in neutral and rev the engine a bit, it did the trick!
Thanks for saving me a tow and $$$ at the mechanic.
maleaecu is offline  
Reply

  Kia Forum > KIA Models > Kia Sorento Forum > 2003-2010 Sorento Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On