Heat blows cold air when stopped - Kia Forum
User Tag List

Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 11-19-2009, 12:17 PM
Newbie
 
Join Date: Dec 2008
Location: Vernon Hills, IL
Posts: 8
Drives: 2004 Kia Sorento EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default Heat blows cold air when stopped

My car is the 2004 Sorento EX 4x4. I just started using the heater again and it seems like its taking a lot longer to warm up. When the car is warm and I'm moving, it blows plenty of hot air, but every time I stop at a light, it changes to cold air. The air temp also seems to cool after I've driven 10 minutes without stopping. I thought I was low on coolant but checked it and its full. Anybody have an idea what I might be in for?
Thanks
jimallison77 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 11-19-2009, 12:36 PM
PLP
Super Moderator
 
PLP's Avatar
 
Join Date: Dec 2008
Location: Haslett, MI, USA, Earth
Posts: 5,927
Drives: 2007 Kia Rondo EX V6 2.7 5P A/T; 2009 Hyundai Elantra GLS, 2.0, I4, 5 SPD M/T sedan
Gallery: 3
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 82 Post(s)
Garage

Default

welcome
fill out profile, please
95% thermostat or 4.5% sludge in cooling system or 0.5% water pump (probability in % based on your testimony) could you tell what the temp gauge says?

www.kiatechinfo.com USA - free service, manuals www.kia.ca/kia-owners-manuals Canada www.kia-hotline.com Europe (paid service!) www.kia.ca/pages/owner/OwnersManual.aspx?lang=en manuals - must pick model, Canadian version - for free
PRINT IT and put on your car Do you talk/text and drive? Watch it: http://www.oprah.com/oprahshow/Watch...bsession-Video
PLP is offline  
#3 (permalink) Old 11-19-2009, 12:59 PM
Memorial Super Moderator
 
pulsar86's Avatar
 
Join Date: Jul 2009
Location: Sunshine Coast,Queensland, Australia
Posts: 2,863
Drives: 2005 Kia Cerato LD [2L petrol] manual, 1986 Nissan Pulsar hatch
Gallery: 3
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)

Thumbs up

I agree with PLP either you have a themostat stuck open or the cooling fan for the radiator is staying on all the time, is your temp gauge reading any lower than it normally does?. If not maybe the tap to open the coolant flow to the heater core when you turn on the heater may only be opening partially, if you havn't used the heater for a while they can stick. It is always a good idea to turn on the heater every once in a while to make sure the taps are free.

TAKE YOUR TIME, THINK IT OUT, DO IT RIGHT, DO IT ONCE!! original quote by me as far as I know. :rolleyes:
ALL MEMBERS PLEASE FILL IN USER PROFILES. DETAILS HELP OTHER MEMBERS HELP YOU .

Last edited by pulsar86; 11-19-2009 at 01:02 PM.
pulsar86 is offline  
#4 (permalink) Old 11-19-2009, 01:58 PM
Veteran
 
Join Date: Sep 2007
Location: Low Country East Coast USA
Posts: 2,876
Drives: 2010 SOUL + Auto (B2522),2010 Soul SPORT Limited Edition Stick (B2581)
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Quote:
Originally Posted by PLP View Post
welcome
fill out profile, please
95% thermostat or 4.5% sludge in cooling system or 0.5% water pump (probability in % based on your testimony) could you tell what the temp gauge says?
Unless you add 95% and 4.5% to get 99.5%. % is based on normal history in here of lack fluid updates. Which is for a vechicle that has not had regular coolent flushes and sludged up and junked up and telling the sensors (fan/gauge) the wrong things and clogging the stat and heatercore flow. If flushes have not been done every two years do one (not just a drain and fill either, as its too late for that) now. And see if it all goes away. or if it gets better. Then do more flushes then you do. Every two years/24,000-30,000 is best.
04SorentoLX is offline  
#5 (permalink) Old 11-19-2009, 04:24 PM
Newbie
 
Join Date: Dec 2008
Location: Vernon Hills, IL
Posts: 8
Drives: 2004 Kia Sorento EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

Thanks for your help. The needle on the temp guage stays pretty consistant right in the middle whether stopped of moving. There was one HOT (100+ plus degrees) day this summer when I had kind of the opposite thing happen with the A/C. The temp guage went way up while I was waiting for a car wash and the A/C blew hot air while stopped. As soon as I started moving, the temp went down and cold air started blowing. That was an isolated incedent and I haven't used the heat or A/C much for last 2 months.
jimallison77 is offline  
#6 (permalink) Old 11-19-2009, 04:29 PM
PLP
Super Moderator
 
PLP's Avatar
 
Join Date: Dec 2008
Location: Haslett, MI, USA, Earth
Posts: 5,927
Drives: 2007 Kia Rondo EX V6 2.7 5P A/T; 2009 Hyundai Elantra GLS, 2.0, I4, 5 SPD M/T sedan
Gallery: 3
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 82 Post(s)
Garage

Default

how long does it take to reach the middle on the gauge? does it stay there on highway?
if everything is fine, the only one thing which left is the suggestion of pulsar86

www.kiatechinfo.com USA - free service, manuals www.kia.ca/kia-owners-manuals Canada www.kia-hotline.com Europe (paid service!) www.kia.ca/pages/owner/OwnersManual.aspx?lang=en manuals - must pick model, Canadian version - for free
PRINT IT and put on your car Do you talk/text and drive? Watch it: http://www.oprah.com/oprahshow/Watch...bsession-Video
PLP is offline  
#7 (permalink) Old 11-19-2009, 05:34 PM
Newbie
 
Join Date: Dec 2008
Location: Vernon Hills, IL
Posts: 8
Drives: 2004 Kia Sorento EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

It takes about 10 minutes of driving to get to the middle of the guage, a lot longer than I remember. After it gets to the middle, it takes another couple minutes before blowing hot air. I remember warm air when the needle got about 1/4 up last year.

how do i fill out a profile here?
jimallison77 is offline  
#8 (permalink) Old 11-19-2009, 05:45 PM
PLP
Super Moderator
 
PLP's Avatar
 
Join Date: Dec 2008
Location: Haslett, MI, USA, Earth
Posts: 5,927
Drives: 2007 Kia Rondo EX V6 2.7 5P A/T; 2009 Hyundai Elantra GLS, 2.0, I4, 5 SPD M/T sedan
Gallery: 3
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 82 Post(s)
Garage

Default

follow the CP symbol above, or this link
http://www.kia-forums.com/usercp.php

so it looks like thermostat.
Just to confirm, no overheating? Any other problems you did not mention?

So, when the car cold, open the hood, check radiator if it is cold.
Then, start engine and keep checking radiator, temp gauge and water pipes, especially this one that goes to heater core, this one that goes to radiator and this which puts coolant back to engine (from radiator).
If all of them are getting warm = thermostat wide open.
Replace it, flush the system and recheck. And update.

www.kiatechinfo.com USA - free service, manuals www.kia.ca/kia-owners-manuals Canada www.kia-hotline.com Europe (paid service!) www.kia.ca/pages/owner/OwnersManual.aspx?lang=en manuals - must pick model, Canadian version - for free
PRINT IT and put on your car Do you talk/text and drive? Watch it: http://www.oprah.com/oprahshow/Watch...bsession-Video
PLP is offline  
#9 (permalink) Old 11-19-2009, 10:17 PM
Veteran
 
kiaracer's Avatar
 
Join Date: Nov 2005
Location: Pittsboro, NC
Posts: 1,252
Drives: 2000 Kia Sephia LS, 1998 Kia Sportage 4x4, 2002 Kia Sportage 4x4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)

Send a message via AIM to kiaracer Send a message via MSN to kiaracer Send a message via Yahoo to kiaracer
Default

probably thermostat stuck open.

"One who is slack in his work is brother to one who destroys."
kiaracer is offline  
#10 (permalink) Old 11-28-2009, 05:09 PM
Newbie
 
Join Date: Nov 2009
Posts: 5
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

I had just purchased a 04 Sorento and I will be taking it into the dealership because of this exact problem. When starting the vehicle cold, even after 20 minutes of idle running time there is no heat YET the temperature gauge is even and stays even. Only when I idle around 2000 RPMs do I get warm air or when I'm on the move. As soon as I stop at a traffic light, COLD AIR! As I just purchased this vehicle I'm taking it back to the dealership as it should be covered under their 90-day lemon law. I will report back what they fixed.

Thanks,
Chris
cgeneral19 is offline  
Reply

  Kia Forum > KIA Models > Kia Sorento Forum > 2003-2010 Sorento Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On