Sorento heater problem - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-14-2009, 11:21 AM
Newbie
 
Join Date: Mar 2009
Posts: 3
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default Sorento heater problem

I have had continous problems with my 05 sorento heater not working. I live in Minnesota and only on the coldest days I go out tostart my car and the heater does not come on. There are no lights on the heater control panel, nothing works. I have had it to the dealer 4 times. The first 2 times the dealer said the plug wiggled loose so they pulled on the wire bundle for more slack. The last time they investigated more with the Kia company and determined they ran another ground wire. It still goes out and stays out.
should I keep bringing it back to the dealer or is there a short somewhere.
I know my trailer harness is corroded, could that be a shorting issue?
tomgvictor is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-15-2009, 11:18 AM
Super Moderator
 
1fastkia's Avatar
 
Join Date: Nov 2004
Location: Vermont
Posts: 6,102
Drives: 08 Sportage, 87 Mazda RX-7
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)

Default

Quote:
Originally Posted by tomgvictor View Post
I have had continous problems with my 05 sorento heater not working. I live in Minnesota and only on the coldest days I go out tostart my car and the heater does not come on. There are no lights on the heater control panel, nothing works. I have had it to the dealer 4 times. The first 2 times the dealer said the plug wiggled loose so they pulled on the wire bundle for more slack. The last time they investigated more with the Kia company and determined they ran another ground wire. It still goes out and stays out.
should I keep bringing it back to the dealer or is there a short somewhere.
I know my trailer harness is corroded, could that be a shorting issue?

Moved, and why would you post this in the site suggestion comment forum. this has to do with your sorento, not kia forums site. make sure when you post you put it in the right forum please. thank you!

08 Kia Sportage
07 Saturn Aura
87 Mazda RX-7
Working on a 07 RX-8

The Old
99 Sephia, 01 Spectra, 05 Spectra
1fastkia is offline  
#3 (permalink) Old 03-15-2009, 05:33 PM
Newbie
 
Join Date: Mar 2009
Posts: 3
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

sorry kind of new to this
tomgvictor is offline  
Reply

  Kia Forum > KIA Models > Kia Sorento Forum > 2003-2010 Sorento Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On