Faulty Throttle Position Sensor (TPS) - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-25-2009, 12:21 AM Thread Starter
Senior Member
 
Aref_Bilal's Avatar
 
Join Date: Jul 2007
Location: Abu-Dhabi, UAE
Posts: 400
Drives: 2005 Kia Sorento EX
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default Faulty Throttle Position Sensor (TPS)

First Signs
• Engine Light comes on (not flashing) when taking your foot of the accelerator while driving and then goes off if you accelerate again.

• Engine Light comes on (not flashing) when you are slowing down before coming to a complete stop and may remain on until you accelerate again.

• Both the above usually occur during a long drive of about 20 min or more and may not occur if you use the car for short trips.


Affect
• Performance becomes very poor & sluggish

• Automatic Transmission quickly changes all 5 gears before reaching the speed of 60km.

• Automatic Transmission refuses to downshift gears when overtaking.

• Manual Tiptronic gears functions and responses are unaffected.


Resolution
• Replace the Throttle Position Sensor (TPS)

• Ensure the P/TRN fuse is disconnected and reconnected to reset the Transmission otherwise the Engine Light problem would have been resolved but the Poor & Sluggish performance will remain.
Aref_Bilal is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-12-2013, 04:29 AM
Newbie
 
Join Date: Mar 2013
Posts: 5
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Hello - Iam just new to this site today and live in Scotland (UK) - I have an 55 Plate Sorento 3.5 V6 Auto with manual shift option and over the last few month when changing up in the auto mode has been double and triple revving sometimes before shifting up. I have did a full AFT RED-1 fluid change and it did seem better but not cured. This morning however when i was in 3rd or maybe 4th gear the car would not change down and became sluggish and when i put over into manual mode it would not register this and the dash continued to show that it was in D - It was not until i stopped and wend through the P, R, N, D with car running and set off again did the gearbox change up and down as normal all be it with some double revving at times - any idea?
Baz3859 is offline  
Sponsored Links
Advertisement
 
Reply

  Kia Forum > KIA Models > Kia Sorento Forum > 2003-2010 Sorento Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On