please help! Won't go over 15mph - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 04-22-2008, 04:06 PM
Newbie
 
Join Date: Apr 2008
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default please help! Won't go over 15mph

hi all, new to the forum, I have this problem with my 04 amanti and have looked for days to try and find possible solutions. My car idles at 2000 rpm and when I press the brakes I hear a thunking sound coming from near the air intake, then when I drive it crawls to 15 mph even when I floor it and won't go any faster!!! Check engine light is on and here are the codes I came up with, what weird is most of them have to do with all the o2 sensors and the mass air flow sensor, p1118 p1178 p0155 p0161 p0135 p0141 p0102. Any help or suggestions would be much appreciated and thanks on advance
bogdan111 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 04-23-2008, 02:52 PM
Full Member
 
Join Date: Oct 2004
Posts: 134
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Sounds like perhaps you may have a bunch of things going on.......I know what I would do at this point, instead of trying to second guess everything, have the dealership check it out and fix it since you can't drive it very many places except parking lots, etc at 15 MPH.......RR
rayray is offline  
#3 (permalink) Old 04-24-2008, 10:29 AM
Full Member
 
Join Date: Oct 2004
Posts: 134
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Quote:
Originally Posted by rayray View Post
Sounds like perhaps you may have a bunch of things going on.......I know what I would do at this point, instead of trying to second guess everything, have the dealership check it out and fix it since you can't drive it very many places except parking lots, etc at 15 MPH.......RR
BTW..........as I have always requested-- if you find out what the problem(s) is/are and what the fix is, how about reporting back to the forum so as others might benefit ..... RR
rayray is offline  
#4 (permalink) Old 04-24-2008, 10:35 AM
Super Moderator
 
ron1004's Avatar
 
Join Date: Jun 2005
Location: Louisville, KY
Posts: 4,398
Drives: Kia Elan
Gallery: 13
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 25 Post(s)
Garage

Default

Quote:
Originally Posted by bogdan111 View Post
hi all, new to the forum, I have this problem with my 04 amanti and have looked for days to try and find possible solutions. My car idles at 2000 rpm and when I press the brakes I hear a thunking sound coming from near the air intake, then when I drive it crawls to 15 mph even when I floor it and won't go any faster!!! Check engine light is on and here are the codes I came up with, what weird is most of them have to do with all the o2 sensors and the mass air flow sensor, p1118 p1178 p0155 p0161 p0135 p0141 p0102. Any help or suggestions would be much appreciated and thanks on advance
There is one problem that could cause all those codes, and that is a leak on the inlet manifold.
The noise when you hit the brake may be related as the brake booster uses vacuum from the inlet manifold.
Search in the area of the inlet manifold for a leak such as a pipe come off.

For service info register (free) with KiaTechInfo and click on 'Shop' on the left, and for elect schematics click on 'ETM'.

Quality and not quantity counts.

Sig image is 500X100 at 11.7 kb
ron1004 is offline  
Reply

  Kia Forum > KIA Models > Kia Amanti & Opirus Forum > 1G Kia Amanti & Opirus Forum


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On