2004 Optima rear speakers - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 11-03-2012, 08:52 AM
Newbie
 
Join Date: Nov 2012
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default 2004 Optima rear speakers

My rear speakers stopped working a long time ago and I was wondering why, I can't see what is wrong. Just recently the front ones stopped working too, a mechanic replaced a fuse and the fronts started working just fine again, but still no rear. I don't understand how there is a fuse for the fronts, is there one for the rears too? Is there an amplifier in the car somewhere? I haven't made any modifications at all. Please help. Thank you.
craig29 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 11-21-2012, 07:45 AM
Newbie
 
Join Date: Nov 2012
Posts: 10
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Check your manual. It will have fuses and fuse placement. Check it for anything that looks like stereo, amplifier, or rear speakers abbreviated. I haven't had this problem myself but I have a LX with the basic audio. If yours is an EX it might have the "premium sound" with and amp, but the amp is usually bolted onto the roof of the trunk close to the speakers or the side.
Kia_Pet is offline  
#3 (permalink) Old 01-20-2013, 08:56 AM
Newbie
 
Join Date: Dec 2012
Posts: 4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

if u have the premium sound system the amp is in the right rear fender well possible the amp is blown the front speakers will still work with the amp blown just not the rears i have same problem hope this helps
tek33 is offline  
Reply

  Kia Forum > KIA Models > Kia Magentis & Optima Forum > 1G/2G (2001-2006) Magentis & Optima


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On