Speedometer Not Working, And Check Engine Light. - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 03-19-2011, 10:16 PM
Newbie
 
Sean298's Avatar
 
Join Date: Oct 2010
Location: Brooklyn Park, Minnesota
Posts: 17
Drives: 02' Optima, 90' Miata, 02' Hayabusa
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage

Thread Starter (Thread Starter)
Default Speedometer Not Working, And Check Engine Light.

2002 Kia optima.

So yeah we had the engine replaced by kia because of a few bad lifters, a week or so later the speedometer stopped working and the check engine light came on. My dad told me to go out and check for any loose wires or something... So i found where the speed sensor is and followed it to a big bunch of taped up cables... and that leads into the "drivers cabin?". so that really didn't help me being 15 and all, we'll probably take it to kia, but hoping for some direction here?


Manual 2002 Kia Optima
Sean298 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 03-21-2011, 07:45 PM
Full Member
 
Join Date: Aug 2010
Location: Pittsburgh, PA
Posts: 79
Drives: 2004 Kia Optima LX V6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage

Send a message via Yahoo to suhail.sood9
Default

I just read 2002 burgundy manual. Make sure you get the timing belt replaced at 60 or 59k miles to be on the safer side

Get it checked by KIA
suhail.sood9 is offline  
#3 (permalink) Old 03-24-2011, 08:51 PM
Newbie
 
Sean298's Avatar
 
Join Date: Oct 2010
Location: Brooklyn Park, Minnesota
Posts: 17
Drives: 02' Optima, 90' Miata, 02' Hayabusa
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage

Thread Starter (Thread Starter)
Default

funny you mention that, we just got the engine replaced at 65k because of a few bad lifters. taking it to kia was our main plan. i dont know how they will be when it has been almost a month since they did it. and we have been putting it off


Manual 2002 Kia Optima
Sean298 is offline  
#4 (permalink) Old 04-05-2011, 10:57 PM
Newbie
 
Sean298's Avatar
 
Join Date: Oct 2010
Location: Brooklyn Park, Minnesota
Posts: 17
Drives: 02' Optima, 90' Miata, 02' Hayabusa
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage

Thread Starter (Thread Starter)
Default

took it to kia and they fixed it, they got no signal from the speed sensor, dad gave the warranty info, I'm pretty sure its ready to be picked up whenever.


Manual 2002 Kia Optima
Sean298 is offline  
#5 (permalink) Old 04-07-2011, 08:36 PM
Full Member
 
Join Date: Aug 2010
Location: Pittsburgh, PA
Posts: 79
Drives: 2004 Kia Optima LX V6
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Garage

Send a message via Yahoo to suhail.sood9
Default

I had the speedo dead issue, no check engine light. The instrument cluster needs replaced. I can live with it
suhail.sood9 is offline  
Reply

  Kia Forum > KIA Models > Kia Magentis & Optima Forum > 1G/2G (2001-2006) Magentis & Optima

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On