Rear defog won't shut off - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 12-28-2012, 04:40 PM
Newbie
 
Join Date: Dec 2012
Posts: 5
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default Rear defog won't shut off

My 04 Kia Rio rear defogger won't shut off, so far I have switched out the relay with the fan relay. Still won't shut off, I also tried another heater control panel. The light is always on and when I push the switch you can hear the relay cycle. The only way I can turn it off is to remove the fuse for the rear defog and the fuse for the mirror heater but the light still stays on. I'm thinking that I may have to wire a switch to each fuse slot.
GLSavoy is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 12-28-2012, 05:08 PM
Expert
 
Join Date: Dec 2010
Location: United States Pine Grove, pa
Posts: 745
Drives: 2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

Default

Being you have heated mirrors try unpluging the the rearefrost timer maybe it's bad just something to check. http://www.kiatechinfo.com/ for schematics. if you pull the relay does the light goes out with the defrost switch turned off? if it does check that timer also good luck with it. Reguards ronjohn
ronjohn is offline  
#3 (permalink) Old 12-30-2012, 09:23 AM
Newbie
 
Join Date: Dec 2012
Posts: 5
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default rear defog

If the timer is beside the relay I unplugged it and no difference, I also unplugged the relay and I am getting 12V on the red green and yellow wires. Being that the green wire is supposed to be the wire that goes to the defroster itself I wouldn't think I should be getting any power from it when the relay is removed. Thanks
GLSavoy is offline  
#4 (permalink) Old 12-30-2012, 09:26 AM
Newbie
 
Join Date: Dec 2012
Posts: 5
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default

BTW, kiatechinfo was a big help, Thanks
GLSavoy is offline  
#5 (permalink) Old 12-30-2012, 12:28 PM
Expert
 
Join Date: Dec 2010
Location: United States Pine Grove, pa
Posts: 745
Drives: 2002 Kia Rio, 2011 Kia Sorento 2005 f 250 1996 geo metro 1992 f 150
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)

Default

Sorry i don't have heated mirrors but my 02 book say's the timer is under the dash left side of the console behind you ventilation controlls. I don't know if your o4 is the same. I would agree with you if you pull the relay out the light should go out and 12VDC should not be present on the green wire look for a short somewhere in the wires hope this help some good luck. Reguard's Ronjohn
ronjohn is offline  
#6 (permalink) Old 01-06-2013, 09:09 AM
Newbie
 
Join Date: Dec 2012
Posts: 5
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default

Sorry it took so long to get back to fixing it. I just started taking out fuses, when I got to the rear wiper fuse the light went out. The rear wiper has never worked for me anyway, and when I put the fuses in for my mirror and defrogger they seem to work fine now. So it looks like when the weather gets warmer i'm going to have to take the panel off the door and just maybe I may find out why my wiper motor isn't working.
GLSavoy is offline  
Reply

  Kia Forum > KIA Models > Kia Rio Forum > 1G (2001-2005) Rio


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On