CD/Radio Stopped Working - Not a fuse - Kia Forum
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-27-2008, 02:43 PM Thread Starter
Newbie
 
Join Date: Mar 2008
Posts: 1
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Question CD/Radio Stopped Working - Not a fuse

I have a 2001 Rio and the radio / cd player stopped working. I thought at first it was a fuse. None inside were tripped, so I checked under the hood. Pulled some out to check, others just touched. All were fine. Even pulled the negative cable off the battery. When I turned the car back on the radio stared working again.

This has happened several times now, each time the radio seems to last a shorter period before it will not come back on again. Can't figure out exactly where/what is the solution, but it seems to be under the hood. Whethere it's resetting by removing the negative cable, a loose fuse, computer, I don't know.

Regardless, the clock always needs to be reset once it comes back on. And the radio will only come on or not when the car starts. Will not come on or go off while the car is on. At least this has been the case thus far.

No other problems exist. I'm going to have the battery and alternator tested, just to rule those out. But right now I'm at a loss.

Anyone have an alternative thought? Or better yet, a solution?

Thanks
Amethaul is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-27-2008, 03:47 PM
Expert
 
2004riotuner's Avatar
 
Join Date: Feb 2006
Location: Whitby Ontario
Posts: 818
Drives: 2004 Kia Rio 2011 Kia Sorento LX V6 AWD
Gallery: 11
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

I would say remove the radio when it is not working and make sure you have 12 volts at the power supply. I'll find a wiring diagram so you'll know what pin it is on the plug.. If you don't have 12V there then you have a power supply problem.. If you do hve 12V then it could be the radio itself.



Here is a link to the wiring diagram.. After looking it over and reading you question again it may be a problem with the ignition switch.. But the power comes in on a brown wire with a red stripe.. If the radio stops working again take the radio out while it is not working and see if there is 12V there if not you have to trace it back to where you find that you have 12V and your problem will be there..

2004 Kia Rio - Garrett GT28R - 1.4 Bar
0-100mph under 13 seconds
How's that for Power to Surprise.

Last edited by 2004riotuner; 03-27-2008 at 03:55 PM.
2004riotuner is offline  
Sponsored Links
Advertisement
 
Reply

  Kia Forum > KIA Models > Kia Rio Forum > 1G (2001-2005) Rio

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On