Broken Timing Belt at 60K - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 07-06-2006, 01:35 PM
Full Member
 
Join Date: Jan 2006
Posts: 110
Drives: 2006 Kia Sedona
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

(Thread Starter)
Default Broken Timing Belt at 60K

A 2003 Rio was hauled into my father-in-law's garage yesterday with a broken timing belt at 60k. Just out of warrenty for the poor fellow. The head reveals broken and bent valves. Pistons are damaged which precludes just a head replacement.

Belt has missing teeth. Guess the scheduled belt replacement at that mileage is not at all optional or something to put off.

George in Wisconsin.
geolehman is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-06-2006, 04:58 PM
Full Member
 
Rio_2002's Avatar
 
Join Date: Apr 2005
Location: Crestline CA
Posts: 181
Drives: 2002 Kia Rio
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

nope its not thats the one draw back to having a rio, i have mine checked every time i get an oil chage
Rio_2002 is offline  
#3 (permalink) Old 07-06-2006, 05:15 PM
Member
 
Chicakia's Avatar
 
Join Date: May 2006
Location: Puerto Rico
Posts: 28
Drives: 2002 Kia Rio
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Quote:
Originally Posted by geolehman
A 2003 Rio was hauled into my father-in-law's garage yesterday with a broken timing belt at 60k. Just out of warrenty for the poor fellow. The head reveals broken and bent valves. Pistons are damaged which precludes just a head replacement.

Belt has missing teeth. Guess the scheduled belt replacement at that mileage is not at all optional or something to put off.

George in Wisconsin.
That happened to me but at 56k...

My English is bad...:cool:

18.6 @ 74
Chicakia is offline  
#4 (permalink) Old 07-06-2006, 11:45 PM
Member
 
wcck's Avatar
 
Join Date: Mar 2006
Posts: 73
Drives: 2002 Kia Rio
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

my belt jumped a few thousand km before it was due to be changed. I got lucky though, and didn't have any valve damage. The belt jumped when trying to start the car and I stopped trying immediatly after hearing something was wrong.

KFX Performance Canada
Same parts, local currency, no import fees.
wcck is offline  
#5 (permalink) Old 07-21-2006, 09:33 AM
Senior Member
 
Benjammin's Avatar
 
Join Date: Jan 2006
Location: Colorado
Posts: 386
Drives: 2011 Kia Soul Base, 2014 Kia Sportage
Gallery: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

The whole interference engine thing scares the piss out of me. I traded my Rio at just shy of 60K miles, so I avoided the whole mess of having it replaced, etc.
Benjammin is offline  
#6 (permalink) Old 07-21-2006, 02:11 PM
Full Member
 
Join Date: Nov 2005
Posts: 140
Drives: 2002 Kia Rio5
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Send a message via Yahoo to byron
Default

hey wcck: quick question. what noise did you hear? recently, I have heard a funny noise "occasionally" when starting the car. a noise I have never heard another car make, and it only does it for a split second as the engine turns overthe first time. sound familiar? I am at 66000 kms and plan on replacing the belt at 70,000kms, 16000 kms early just to prevent this possible problem. thx. bm
byron is offline  
Reply

  Kia Forum > KIA Models > Kia Rio Forum > 1G (2001-2005) Rio


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On