Stalling at idle - Kia Forum
User Tag List

 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 01-17-2013, 07:58 AM
Member
 
Join Date: Apr 2008
Location: Middle East
Posts: 70
Drives: 2000 Sportage A/T 4X4
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default Stalling at idle

It's been two days now that my sporty stalls at idle, most especially in long traffic. Can't check it with a scanner because it has the odb1 under the hood, so I just shorted the "test" and "gnd" and it gave me eight quick flashes. Eight quick flashes corresponds to the MAF, so I removed and cleaned with carb cleaner the MAF and added the IAC while at it. Disconnected the battery for a minute or two to reset the ECU then I replaced the air filter and reinstalled the MAF and IAC . Started the engine, waited for normal engine temp then roamed a bit, didn't stall at first, waiting for the green light at signal then suddenly the check engine light lit then engine rumbles and died but it started up easily when I turned the key. Checked again the flashes and still gave me eight quick flashes, so I just bought and installed a new MAF after reseting the ECU. Drove a bit for few miles then I thought it was OK but I stopped at the signal near my house, check engine light lit and engine rumbles then died again. It just stalls at idle but the performance is great and engine always starts quickly. Hope you guys could help with this, thanks!!!
rlingdas is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 01-17-2013, 11:23 AM
Expert
 
Join Date: Feb 2010
Location: Rome, Italy
Posts: 748
Drives: 1999 Sportage A/T 4WD
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)

Default

When it stalls connect the terminals 1 and 5 of the diagnosis connector (the one that you say it is OBD1, but it is OBD2) with a jumper wire; if it stops stalling then replace the fuel pump relay.

If you cannot display a picture of mines and you would like to display it, send me a message and I will try to update that immage address, so that it can be displayed.
Galf is offline  
Reply

  Kia Forum > KIA Models > Kia Sportage Forum > 1G (1994 - 2002) Sportage

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On