Kia Gas engine sounds like a diesel.? - Kia Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 13 (permalink) Old 08-01-2010, 07:20 PM Thread Starter
Full Member
 
dj-vega's Avatar
 
Join Date: Jul 2010
Location: Norway - Rogaland
Posts: 133
Drives: Kia Sportage 1995 2.0 Dohc
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default Kia Gas engine sounds like a diesel.?

Hello.

Is it normal that KIA Sporty engine sounds a bit like a diesel engine? Mine really reminds me of a diesel compared to eg a 1.8L Volvo Engine. Is there a reason for this?



1995 Kia Sportage 2.0 4WD
Probably the most expensive 95 kia in my area...But who cares :P
dj-vega is offline  
Sponsored Links
Advertisement
 
post #2 of 13 (permalink) Old 08-13-2010, 10:54 PM
Member
 
Join Date: May 2010
Location: Manila, Philippines
Posts: 25
Drives: Kia Sportage '96
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

also have the same problem... it just started 3 weeks ago.. theres this ticking sound when you start the engine and after pressing the gas pedal... very weird. some say it has something to do with the tappets that needs to be adjusted. but i know for sure that it doesnt suppose to sound like that. do we have the same issue?

can someone please shed some light on this?
topher is offline  
post #3 of 13 (permalink) Old 08-14-2010, 02:08 AM
Expert
 
Join Date: Feb 2010
Location: Rome, Italy
Posts: 763
Drives: 1999 Sportage A/T 4WD
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)

Default

If it comes from the tappets I think it could be a lack in the lubrification. You should use a good oil, I think the best for my Sportage DOHC engine is 5-40W, change it every 10,000 Km or every six months, and replace the oil filter preferably with the original oil filter from KIA. But if you have used mineral oil it is better that you don't switch immediately to synthetic oil, but you should use half-synthetic oil (10-40W) before switching to synthetic oil (5-40W).

But before using half-systhetic or synthetic oil check if the engine of your car can use them, because I am referring to my '00 Sportage DOHC engine and I don't know what engine there is on your '96 Sportage.

Last edited by Galf; 08-14-2010 at 05:13 AM.
Galf is offline  
post #4 of 13 (permalink) Old 08-14-2010, 03:12 AM
Member
 
Join Date: May 2010
Location: Manila, Philippines
Posts: 25
Drives: Kia Sportage '96
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

i thought of that and only added mineral oil/ordinary havoline oil, but with no luck. im still hoping it could change if i change the oil completely and replace the filter. my dilemma though is, if it doesnt work and tappets needs to be adjusted, i would have to change the oil entirely again as it will be contaminated.

so you think i should have the tappets checked first then change oil?

or try to change oil and filter and hope it works out? but with the possibility of tappet adjustment and another change oil?
topher is offline  
post #5 of 13 (permalink) Old 08-14-2010, 01:22 PM
Expert
 
Join Date: Feb 2010
Location: Rome, Italy
Posts: 763
Drives: 1999 Sportage A/T 4WD
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)

Default

I would replace the oil with half-synthetic oil 10-40W and the oil filter with the original oil filter from KIA. After 10,000 Km or six months I would replace again the oil with completely synthetic oil 5-40W and the oil filter with the original oil filter from KIA.

I have checked on Castrol web site: your Sportage can use 5-40W synthetic oil.

Last edited by Galf; 08-14-2010 at 01:25 PM.
Galf is offline  
post #6 of 13 (permalink) Old 08-16-2010, 08:42 AM Thread Starter
Full Member
 
dj-vega's Avatar
 
Join Date: Jul 2010
Location: Norway - Rogaland
Posts: 133
Drives: Kia Sportage 1995 2.0 Dohc
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

Hello.

I just started up my Kia. It had a ticking noise today. Other times it starting up without any ticking noise, do you are experiencing the same thing, ( that the ticking sound comes and goes.?)

Thanks

1995 Kia Sportage 2.0 4WD
Probably the most expensive 95 kia in my area...But who cares :P
dj-vega is offline  
post #7 of 13 (permalink) Old 08-17-2010, 01:55 AM
Member
 
Join Date: May 2010
Location: Manila, Philippines
Posts: 25
Drives: Kia Sportage '96
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

i have others saying it comes from the valves... il have mine checked within the week. i'll keep you posted.
topher is offline  
post #8 of 13 (permalink) Old 08-20-2010, 12:11 PM
Member
 
Join Date: Oct 2009
Location: RAMAT GAN, ISRAEL
Posts: 32
Drives: 2001 kia sportage
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

Quote:
Originally Posted by topher View Post
i have others saying it comes from the valves... il have mine checked within the week. i'll keep you posted.
it might be a result of hot climate - on my sportage we had the same pronlem when summer came- some severe tappet noise occured, especially on start up. an oil change to 10/40 solved the problem. plus make sure your oil level is correct
hadtomer is offline  
post #9 of 13 (permalink) Old 08-20-2010, 06:19 PM Thread Starter
Full Member
 
dj-vega's Avatar
 
Join Date: Jul 2010
Location: Norway - Rogaland
Posts: 133
Drives: Kia Sportage 1995 2.0 Dohc
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Thread Starter (Thread Starter)
Default

I use the 10-30 oil. Thats what the owners manual says.

1995 Kia Sportage 2.0 4WD
Probably the most expensive 95 kia in my area...But who cares :P
dj-vega is offline  
post #10 of 13 (permalink) Old 08-28-2010, 10:34 AM
Member
 
Join Date: May 2010
Location: Manila, Philippines
Posts: 25
Drives: Kia Sportage '96
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)

Default

after an engine flush, change oil (ordinary mineral oil) and change the oil filter. the tapping noise went away!!!!

BUT... there's this huge cloud of white smoke now every morning. I checked the oil level and its normal... any guess? i dont think there's a new problem, but maybe some oil went to something? help please.
topher is offline  
Sponsored Links
Advertisement
 
Reply

  Kia Forum > KIA Models > Kia Sportage Forum > 1G (1994 - 2002) Sportage

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Kia Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On