Kia Forum - View Single Post - UVO Radio stopped working
View Single Post
post #8 of (permalink) Old 01-22-2015, 09:07 AM
Moparmatt
Newbie
 
Join Date: Jan 2015
Posts: 8
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)

Unhappy Radio not working as far as sound

This is so frustrating, car is 2013 kia soul with 60,500 miles. Radio comes on, camera works, blue tooth connects but NOTHING for sound, lost presets and time, have reset radio, pulled fuses to no avail.. I play with old cars and have 40 year old radios that work fine, dealer who sold us car raved about UVO system and how awesome it is.....2 1/2 years later......worthless!!!! We have owned the car for 2 1/2 years now and have raved about car to all that ask about it, probably have sold 5 kia souls at least as a bird dog (person who brings customers to dealer), never did it to get commission or thanks, did it because we loved the vehicle. That is all about to change. Start by saying our fault for not reading the fine print or paper work, but our salesperson did a bang up job of stating the 10 year, 100,000 mile warranty on numerous sales pitches, honestly leading both my wife and myself to believe there was a 10 year warranty bumper to bumper, no, radio is 3 year 36k miles! What? I have a radio that is 2 1/2 years old that won't be repaired/replaced because of mileage? Oh, and the rear window electric motor-not covered-out of warranty, the front end...that is wear parts-not covered, motor, trans and axle only sir. Heart broken in NJ, had a mad crush on this car-my little go-cart, people asked me all the time why I drive this when I have the other "cool" cars and a truck and I told them how awesome this thing is, now...probably gonna buy a dodge dart or look into other cars, KIA is no different than other makes and models, their great 10/100k warranty, average.
Moparmatt is offline